6

SO appears to have change recently, with respect to the questions page. It may be to do with the "new" tab functionality, I am not sure.

Previously, it was possible to order the questions by "Newest" and then after having jumped to page 2, then one could directly manipulate the page parameter in the URL, as described in Why can't I Jump to a Page Directly?, like so:

http://raspberrypi.stackexchange.com/questions?page=5&sort=newest

However, now, on SO, it seems that is no longer possible, as irrespective of which page one is on, the URL is always

http://stackoverflow.com/questions

One can only select the pages offered at the bottom of the page:

Page selector

If I am trying to get to the page for questions in January, for example, how can I do that, without having to repeatedly scroll to the bottom and selecting only two pages along from where I already am?

If I am missing something then I apologise.

Other sites still behave as before - this new behaviour only appears to be on SO.

  • Have you checked M.SE to see if it happens here too? If memory serves, new-nav is being tested here as well. – Nathan Tuggy Apr 7 '16 at 6:21
  • @NathanTuggy - It works as before on Meta. The new functionality doesn't appear to have been implemented on Meta - yet... – Greenonline Apr 7 '16 at 6:25
  • Oh, did you check to make sure you're opted into the new-nav test here? I thought they were synced but maybe not. – Nathan Tuggy Apr 7 '16 at 6:36
  • @NathanTuggy - I have just checked and I do appear to have opted in (probably for quite some time now, as I can't remember clicking on it recently). Is this opt-in checkbox site specific or SE wide? I presumed that it was SE wide. – Greenonline Apr 7 '16 at 6:39
  • New Navigation seems to be set per-site because I see it on my Profile for Stack Overflow and Meta Stack Exchange but not for Genealogy & Family History or Geographic Information Systems. – PolyGeo Apr 7 '16 at 7:28
  • @PolyGeo - My opt-in is set for both Meta and SO, but there is no such option available on Raspberry Pi, nor on SuperUser, nor ServerFault. It must only be available for certain sites. – Greenonline Apr 7 '16 at 7:38
  • My "not set" for the other two sites is because it is not available there as a checkbox too. I am thinking this issue is Stack Overflow specific and not directly related to the New Navigation. – PolyGeo Apr 7 '16 at 7:41
2

This is still possible, you just have to type (or paste) a little more than the page number you want.

If you append the page parameter to the end of the url, you're taken to that page in the list. The url will revert to what it shows now, but you won't have your page changed back.

For example, https://stackoverflow.com/questions?page=5 still takes you to page five of the Stack Overflow questions, the url will just change back to https://stackoverflow.com/questions once there.

However, if you were to refresh on page five, you will be taken back to page one. This is apparently intentional. (Check the comments of that answer for the details exchange.) If you want to remain on that page, I recommend copying your modified url and pasting it rather than refreshing. It's obnoxious, but how we currently need to work around this.

The above is all true for (M)SO, but not for MSE.

|improve this answer|||||
0

This works on three Stack Exchange sites that I tested:

so the issue you are encountering, that I can reproduce, seems to be Stack Overflow specific, or at least not Stack Exchange network-wide.

In case it is relevant I opted into the New Navigation for Meta Stack Exchange quite a while ago:

enter image description here

I am also using the New Navigation on Stack Overflow so I think this issue is unrelated to the New Navigation.

|improve this answer|||||
  • Yes, it is only on SO. All of the other sites appear to be unaffected. The change seems to be a new feature, possibly being tested on SO. Sorry, I should have made that point clearer in my post. I shall update. – Greenonline Apr 7 '16 at 6:00
  • I think that should mean migration of your question to [meta.so] will be appropriate. – PolyGeo Apr 7 '16 at 6:01
  • I can see your point. However, I assumed that if it has been rolled out on SO, then it may in future be rolled out to all sites, as many new features appear to be "beta'd" (as it were) on SO first. Hence why I posted it on Meta, rather than SO meta. – Greenonline Apr 7 '16 at 6:04
  • I'm used to asking questions on Beta software using Beta discussion forums. Stack Overflow probably won't like being termed a forum (because it's not) but I do think the place to address this is through its per site Meta rather than this network-wide one. – PolyGeo Apr 7 '16 at 6:10
  • Isn't the new-nav SO and M.SE specific? – Nathan Tuggy Apr 7 '16 at 6:20
  • @NathanTuggy I'm not sure about the new-nav but this issue does not appear here at Meta Stack Exchange - try meta.stackexchange.com/questions?page=5&sort=newest – PolyGeo Apr 7 '16 at 6:30
  • @NathanTuggy It seems to be unrelated to the New Navigation because I have opted into that on both Meta Stack Exchange and Stack Overflow. – PolyGeo Apr 7 '16 at 7:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .