11

On Latin.SE, I am getting a 404 error when clicking any of the three "history" links on the tour page. That is, this:

Top of the tour page, clicking history link

Gives this:

404

All three editable sections have a revision history with two revisions or more, and all three give an error. The actual links are 1, 2, and 3.

  • @ShadowWizard Hmm; when I click edit I get an inline edit box, not that message, and your direct edit link works too (but I'm a mod on Latin). I wasn't aware that changes on the tour were subject to approval; I don't see any indication of that. – Nathaniel Apr 18 '16 at 21:15
  • Hmm... so it means that error message is just generic, and pointless in this case. Doesn't really matter since non-mods should never visit such a link. Anyway, you get that error you mention when submitting the edit? – Shadow The Dragon Wizard Apr 18 '16 at 21:17
  • @ShadowWizard Nope, I just made a trivial edit and it went through without an error. I only get the error when clicking the "history" link; the edit link seems to work fine. – Nathaniel Apr 18 '16 at 21:20
  • You mean you get error when trying to view revisions? I see them just fine, try to visit the links in Private/Incognito mode of the browser and see what happens – Shadow The Dragon Wizard Apr 18 '16 at 21:26
  • @ShadowWizard I get the same error in icognito mode. We're talking about the same history link, right? The one in my first screenshot? – Nathaniel Apr 18 '16 at 21:32
  • Only mods see the link in the tour page itself, but I did click the link you posted yes. – Shadow The Dragon Wizard Apr 18 '16 at 21:51
  • @ShadowWizard Okay, interesting. I get the same behavior clicking the link on the tour page, and clicking the links in this post, in chrome and in chrome incognito. – Nathaniel Apr 18 '16 at 21:53
  • This query returns revision histories that moderators on that site can’t see, but everyone else can. (Confirmed for scifi.SE, at least.) – yellowantphil May 20 '16 at 5:13
6

We were not handling the tour post type when showing revisions for moderators properly (an oversight during creation of the post redaction tool).

I have fixed this issue - will be with you in the next build (rev 2016.5.20.3597).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .