I came across this answer: https://stackoverflow.com/a/37046491/, yeah looks spammy to me. But when I notice the code inside it:

Have a look on [properly-testing-ionic-framework-mobile-application][1]

  [1]: https://www.thepolyglotdeveloper.com/2015/02/properly-testing-ionic-framework-mobile-application/

It was the above. But when I tried to hover over the link, something crazy happened:

enter image description here

If you see the image's URL on the status bar or if I click, it goes somewhere else and not the right location. But it looks good in the preview when editing.

enter image description here

Is this a bug with our Markdown Parser?

Using the JavaScript preview, the correct URL comes up in the Status Bar:

enter image description here

  • 2
    No repro for me. This is most likely something on your side, probably some user script you installed and forgot about by now. Try with clean browser. If still no luck, add your browser/OS details please. Commented May 5, 2016 at 9:48
  • 2
    What browser/OS are you using when seeing this?
    – Oded
    Commented May 5, 2016 at 10:03
  • @ShadowWizard "If you see the image's URL on the status bar or if I click, it goes somewhere else and not the right location." suggests that it's not just the status bar, but the link itself is wrong. Commented May 5, 2016 at 10:03
  • @Andras not really. From what I understand, OP means the status bar in the screenshot. Commented May 5, 2016 at 10:24
  • 1
    @Oded Chrome 49 on Windows 7. Commented May 5, 2016 at 10:41
  • I am on the same. I had noticed that Chrome will show a truncated URL (usually with ellipses where things were removed) for very long URLs, but if you keep hovering over the link, it will eventually expand.
    – Oded
    Commented May 5, 2016 at 10:48
  • @Oded But it will not redirect me to properly-testing-ionic-framework-mobile-application right? Click on the previous link. Commented May 5, 2016 at 11:13
  • @PraveenKumar - as far as I could tell, it would go to the correct place, it is just a display thing on Chrome.
    – Oded
    Commented May 5, 2016 at 11:41
  • @Oded It's not the UserScript, it's not the browser, it's not me. It's shouldiblamecaching.com. :D Commented May 5, 2016 at 11:52

1 Answer 1


I had visited the same post as you did. This is not a bug.

What happened was that the original answer did not have the correct link. When the user realized this, he made the edit. As this edit was made in the grace-period, it was not recorded.

This edit was done before the first comment was added. It is most likely that this edit was not loaded, when you were viewing the answer, and you took the first image. You could see the change of link in the third image, as it was loaded. If you would've refreshed the page, you could see the difference.

I have two points to prove this:

  • I had visited the link before the edit was made, and I just got an error from chrome saying that the page does not exist. Although, I had not visited the link after the edit.

  • I clearly remember the author of that answer leaving a comment saying that he had by mistakenly not linked the article correctly. He left this comment, after few users told that the answer was link-only (OP must have thought that they were talking about the wrong link).

Here's an image of that comment:

enter image description here

I'm using Chrome on Ubuntu 14.04 LTS.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .