7

freehand circles ftw

The diamond should be in the same line as moderator's name. Adding a non-breaking space after the name, and removing margin-left: 3px; CSS rule from .mod-flair fixes that.

Reproduced in Chrome, but not in Firefox.

On this particular comment it happens only when logged in, because

the space reserved for the comment vote and flag buttons reduces the width of the comment text column by a few pixels. Those buttons are not present if you're not logged in, leaving a bit more room for the comments themselves. Carefully tweaking the comment text length (or column width) using the dev tools can still trigger it.

(as pointed out in comments by Ilmari Karonen)

  • What browser are you using? I cannot reproduce this on Firefox, and there's already an a.comment-user { white-space: nowrap } CSS rule that should prevent this from happening on any browser. I suspect this may be a browser bug. – Ilmari Karonen May 18 '16 at 14:22
  • What OS? Looks like you're on mobile, android to be exact, based on the red diamond color. – Shadow Wizard Wearing Mask May 18 '16 at 14:29
  • @ShadowWizard No, I'm on desktop and my OS is Linux Mint. – Michał Perłakowski May 18 '16 at 14:31
  • @IlmariKaronen I'm using Chrome. – Michał Perłakowski May 18 '16 at 14:32
  • 3
    Thanks, this is indeed reproducible on Chrome/Chromium. The reason it only happens for that particular comment when logged in is simply because the space reserved for the comment vote and flag buttons reduces the width of the comment text column by a few pixels. Those buttons are not present if you're not logged in, leaving a bit more room for the comments themselves. Carefully tweaking the comment text length (or column width) using the dev tools can still trigger it. – Ilmari Karonen May 18 '16 at 14:41

You must log in to answer this question.

Browse other questions tagged .