9

The following image URL fails to upload via Link from the web:

http://quod.lib.umich.edu/j/jep/images/3336451.0007.104-00000002.gif

The URL doesn't contain spaces as described here.

Other URLs:

  • The error means the format of the image itself is not supported, not related to the URL. – Shadow The Dragon Wizard May 20 '16 at 17:53
  • Also, can't reproduce, just tried it now and it worked fine: i.stack.imgur.com/6taWr.gif – Shadow The Dragon Wizard May 20 '16 at 17:54
  • It does happens on Chrome (OS X), e.g. in a new post click on Image button, then paste it in Link from the web. Does it really work for you? – kenorb May 20 '16 at 17:56
  • 6
    The system saw that image and couldn't stop laughing at it in order to upload it. – Won't May 20 '16 at 18:31
  • 3
    Huh, so weird.. it worked for me in the first time but now it's failing indeed. Still, in Chrome you can right click the image itself, click "Copy image" then click CTRL+V in the uploader to paste the raw image itself, and then upload. Works for me even now that using the URL fail. – Shadow The Dragon Wizard May 20 '16 at 19:01
  • Can reproduce with Chrome, Win X – ArtOfCode May 21 '16 at 20:26
  • Worth to mention, uploading directly to imgur.com works fine, meaning the problem is within the API. – Shadow The Dragon Wizard May 22 '16 at 5:57
3

Got it, no bug after all and I'm amazed it took me so long to spot what's going on.

The images are not stored on umich.edu domain, but rather on a different domain.

When going to http://quod.lib.umich.edu/j/jep/images/3336451.0007.104-00000002.gif the server is sending a 302 header, with the new location:

Browsers of course can handle this properly, and so imgur.com itself, which check for such header, however Stack Exchange is using API provided by imgur, which does not check for such header.

You can try starting a feature request asking to support those cases, and until then just use the "real" URL of the images, e.g. http://www.journalofelectronicpublishing.org/images/3336451.0007.104-00000002.gif which works fine.

  • Great investigation. I'd say it's still a bug (not a feature), since from the user perspective you expect this image to be uploaded (like it works at imgur), but it fails on SE specifically. – kenorb May 22 '16 at 12:11
  • @kenorb well, it's like the API of SE themselves lack some things, e.g. way to send a delete vote. However, not being able to delete via the app is not a bug. Same logic applies here, in my opinion. – Shadow The Dragon Wizard May 22 '16 at 12:27
  • Thanks for explanation and suggestions, I've opened the feature request then. – kenorb May 22 '16 at 12:40
  • But, if the error message is really "Failed to upload image; the format is not supported" or something like that, it's an incorrect error message, and that's a bug, isn't it? – Peregrine Rook May 23 '16 at 20:08
  • @PeregrineRook well, that's the generic API error message, see also here and here for couple more cases. I'm not sure how it works with the API, probably it's not really giving the "correct" message, letting the code consuming it guess or perform its own checks/validations. Yet again, not fully SE responsibility, though they can probably do it. – Shadow The Dragon Wizard May 23 '16 at 20:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .