7

The filtered question list available at https://stackexchange.com/filters no longer seems to exclude questions that have been deleted. This was working fine until perhaps a few weeks ago.

This appears to be true whether or not I have the ability to view those deleted questions on the site in question. I think that deleted questions should always be removed from the filtered question list, regardless of user privilege level.

Here's an example. The filter is https://stackexchange.com/filters/245090/test-filter-to-show-deleted-question. The highlighted question leads to https://bitcoin.stackexchange.com/questions/46211/traffic-bitcoins.

enter image description here

2
  • Can you give some examples? Might be cache of few minutes. Jun 27 '16 at 20:33
  • @ShadowWizard: I know there used to be a cache. I'm currently looking at a 9 hour old question, deleted 7 hours ago, that still shows up in the filtered question list. Jun 27 '16 at 20:34
7

This appears to be a bug in the replacement "tag engine" code that we've recently deployed. I am investigating.


Update: identified and fixed; deploying ASAP. Thanks for noticing :)

The problem was a "where {not deleted}" clause that should only have been included in the initial load (no point loading questions that are already logically deleted) - but that clause should not have been included when loading delta changes, because we need to merge the deltas of (logically) deleted questions with the in-memory data to ensure that deleted questions disappear. It didn't show up on the main sites because we include a "get the latest version and remove deleted" in the UI code, to avoid issues associated with cache.

Note: it looks like the filters have a relatively long cache, but it will clear, honestly! I've manually checked all the backend nodes for this, and they all indicate that this is fixed.

7
  • While at it, I couldn't help noticing "1 answers" in the filter results - can it be fixed? :-) Jun 28 '16 at 13:03
  • @ShadowWizard where did I leave that giant S... just kidding; but: we currently do not use our translation and pluralization suite (aka "moonspeak") on se.com; on the main sites, this could be a simple change - here, not so much Jun 28 '16 at 13:08
  • lol, OK, fairs enough. ;) Jun 28 '16 at 13:37
  • @MarcGravell: Either this regressed or it isn't actually fixed. See the same filter, the deleted question bitcoin.stackexchange.com/questions/46270/… still shows in the filter. Jun 29 '16 at 23:57
  • @greg dammit; well I guess that answers the question of what to do on a Thursday... Jun 30 '16 at 0:02
  • @GregHewgill k, should be fixed when I've finished this deploy; full end to end unit+integration tests now should prevent recurrence Jun 30 '16 at 10:49
  • @MarcGravell: Thanks, I'll keep an eye out to verify! Jun 30 '16 at 19:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .