6

As mentioned in this answer, when tapping a comment in the Android app, we should have a reply icon, letting us reply to the comment, instead of the auto complete on the site:

However, when I tap a comment I get the "flag" icon instead of reply icon:

What is going on? Can this please be fixed?

  • 1
    Not a bug, and not required. There is a reply icon, which does not exist on the site. – ShaWiz Jun 27 '16 at 22:08
  • I'm using v1.0.85 and where the reply button should be according to that other question there is a button to flag the comment instead – Nic Jun 27 '16 at 22:14
  • @ShadowWizard Although the interface changes between a showing a reply arrow and a triangle with an exclamation mark in. So it is a bug – Nic Jun 27 '16 at 22:16
  • Same version here, I see reply and flag icons when tapping a comment made by someone else, and link to profile and delete when tapping my own comment. Never saw triangle with exclamation mark, can you please post a screenshot? – ShaWiz Jun 27 '16 at 22:29
  • That is really weird. What happens when you tap that icon? Is this flagging? What you get when clicking the three vertical dots? – ShaWiz Jul 1 '16 at 21:47
  • @ShadowWizard so the option to flag disappears from the three dots menu and is now accessed by the warning triangle. Seems silly that the reply function completely disappeared – Nic Jul 1 '16 at 21:56
  • 1
    OK, I have rewrote this as a bug report and reopened. As feature request it would just be a duplicate. – ShaWiz Jul 1 '16 at 22:13
1

This is fixed as of version 1.0.94 going live right now.

Per the release notes:

The "Reply" button in the action bar when selecting a comment is now usable while already writing a comment

When the commenting UI is visible, the post which you are commenting on doesn't show the "Add Comment" button, since you're already commenting on it. You can see this in the second screenshot in the question vs the first one.

The issue ended up being that we used the same can_add_comment variable to control showing both that "Add Comment" button, and the Reply button. When that commenting UI is open, to hide the "Add Comment" button we set can_add_comment to false, which then caused the Reply button to disappear too.

As of version 1.0.94, we use a can_add_comment variable and a is_mid_commenting variable, which lets us hide the "Add Comment" button separately from showing/hiding the Reply button.

It's not perfect, because you can keep on hitting Reply on the same comment over and over again and each time it'll add the @Username to the front of your pending comment, but it makes a whole lot more sense than what was happening before.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .