4

I wrote a comment to this question on math-stack-exchange.

The browser (both Chrome and Firefox) didn't take it very well, and spread it all over the webpage, such that both the 'edit' option and the 'delete' option are shadowed (unavailable):

How can I resolve this?

P.S.:

I kept adding comments, hoping I could get it fixed and then delete the previous ones.

I realized that the 'delete' option was unavailable only after repeating this several times.

  • meta.math.stackexchange.com – E.P. Jul 24 '16 at 10:41
  • That does seem like a bug - the display is what happens if you add invalid MathJax code in a comment, but the formula is correct. Funnily enough, though, if you (1) copy the formula into the answer box and then (2) add dollar signs, for some reason it shows an error. If you change the last \rfloor to, say, ), and then back, then it works. If you copy-paste with the dollar signs included it also works. There's some funky edge case getting called there. In any case, you've posted it as an answer so you can just delete your comments (or flag for deletion if you can't). – E.P. Jul 24 '16 at 10:43
  • 1
    @E.P.: Thanks, posted it there instead (here). Will delete this one shortly I guess. – barak manos Jul 24 '16 at 10:44
  • @E.P.: BTW, I'm pretty sure that the LaTex formula was valid at some point (in the last few comments). It's just that when using a long formula in the comment section, one must add a few sporadic spaces here and there (the browser doesn't take it very well as soon as there are too many consecutive non-space characters). – barak manos Jul 24 '16 at 10:46
  • I'm pretty sure I know what's going on, I'll post on meta.math when I've got it nailed down. Long story short is that somehow a non-displaying unicode space snuck into your last \rfloor. Delete it and re-type it and it should work fine. – E.P. Jul 24 '16 at 10:59
  • @E.P.: I am aware of the problem that long LaTex formulas with no space characters aren't handled very well when posted in the comment section. I am merely trying to resolve the case at hand, where I am unable to edit or delete those comments due to the mess on my screen. – barak manos Jul 24 '16 at 11:03
  • See my answer on meta.math and Asaf's comments there. Your browser should have an Inspect Element option upon right click which you should be able to use to hide the banners that are currently blocking the edit and delete buttons. If that doesn't work, flag for moderator attention. – E.P. Jul 24 '16 at 11:08
  • @E.P.: Thanks. I got as far as 'Inspect Element'. Can't see how to hide an element at this point. – barak manos Jul 24 '16 at 11:17
  • The procedure depends completely on what browser and system you're using. In Chrome, hovering over the html tags in the Elements tab of the dev tools shows you what you're selecting on the page. To hide an element, right-click the tag and select Hide Element. In other browsers - no idea. – E.P. Jul 24 '16 at 11:22
  • @E.P.: Thank you, I'm on Firefox (will have to login with Chrome). – barak manos Jul 24 '16 at 11:23
  • In Firefox you can use Delete Node, if you get the <div id="sidebar"> it should work. – E.P. Jul 24 '16 at 11:26
  • A related post: MathJax in Comment Gets Corrupted. – Martin Aug 19 '18 at 10:19
2

Until this is fixed, you can delete those comments by opening your browser's Console (typically F12) then typing these lines of code, one at a time, and pressing Enter: (as it's rate limited)

$.post("/posts/comments/3829630/vote/10", {"fkey": $("#fkey").val()});
$.post("/posts/comments/3829648/vote/10", {"fkey": $("#fkey").val()});
$.post("/posts/comments/3829649/vote/10", {"fkey": $("#fkey").val()});

Note: you will not get any confirmation dialog, the comments will be deleted instantly.

To delete further comments this way, all you need is their ID which can be retrieved from the permalink. (the comment's timestamp is a permalink, e.g. https://math.stackexchange.com/questions/1869322/can-this-function-be-a-new-test-for-primality#comment3829630_1869322 and the ID is 3829630)

In case the timestamp itself is hidden, the comments are also available in your profile page, the title of each comment is the permalink with the comment ID.

| improve this answer | |
  • Thanks. Typing these lines of code... where? (There doesn't seem to be any edit-box for that purpose). – barak manos Jul 24 '16 at 11:32
  • @barakmanos what browser are you using? If Chrome, press F12 in the keyboard, then go to Console tab and type it in there. – Shadow Wizard Wearing Mask Jul 24 '16 at 11:37
  • I'm using Firefox, thanks. – barak manos Jul 24 '16 at 11:47
  • 1
    @barakmanos in Firefox it's CTRL+SHIFT+I – Shadow Wizard Wearing Mask Jul 24 '16 at 11:49
0

Several ways how to get to the delete/edit button are suggested in the posts on Mathematics Meta on this topic, see: My comments got stretched across the screen, and it won't allow me to edit or delete the comment either.

To me, the simplest way seem to be changing the Math Renderer. (You can do this in the MathJax menu which you get after right click on a rendered formula. [This post](Slow editing in new website)has a screenshot showing the menu.

You can try various renderers to see which allow you shorter comment. If nothing else, choosing Plain Source as Math Renderer should help with this. (And after fixing the comment you switch this back the the one you prefer.)

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .