3

I often look at the Hot Network Questions list in the various topics that I participate in. The questions are usually interesting (for obvious reasons), so I read them, and the answers, and give up/downvotes all around (including on comments). If I ever upvote a question, I almost always upvote an answer, and vice-versa, assuming that the quality is good. I usually upvote comments that I find useful/interesting/funny as well.

Just yesterday I voted on this User Experience HNQ question, as well as the currently top up-voted answer. I also upvoted this highly-upvoted comment.

I came back to it today to see if there were any new answers, and to my surprise I saw this:

voting failure

The thing to note is that the answer wasn't upvoted, though I distinctly remember upvoting it.

This happens infrequently, but often enough that now I'm writing on Meta about it. It seems that sometimes, my votes aren't recorded. This seems to happen most often with Hot Network Questions. I frequent Programmers, Academia and StackOverflow the most, and I often re-read Q/A that I read/upvoted that week, only to come back to find that my votes weren't recorded (when I distinctly remember upvoting those questions and answers).

Has anyone else experienced this? Is this an actual issue or am I being delusional?

In response to comments, I use the web app as well as the iOS app, but more frequently the web app. I'm suspecting that an error occurs during voting, but I happen to navigate away from the Q/A before the error propagates back to me, rendering it essentially 'invisible'. I don't see my answer up-vote for this UX question in my votes tab.

  • How are you voting? On the actual website or are you using some version of the App? I feel like I've heard similar complaints about the Android App but I'm not sure. – Catija Aug 3 '16 at 16:23
  • Well, I haven't double checked whether my votes get through, but due to a lot of reasons, the system may give an error when you wanted to submit your vote. "An error occurred - please retry your request.". – Marshmallow Aug 3 '16 at 16:23
  • Do you see the votes in the votes tab? – ShaWiz Aug 3 '16 at 16:24
  • @Catija I use both the website and the iOS, but more frequently the website. TIPS - true. Sometimes I get that error, but these are cases when there was no error, but the vote wasn't recorded. Perhaps I'm navigating away from the Q/A faster than the error propagates, so I don't see it and it's silent? – Chris Cirefice Aug 3 '16 at 16:25
  • @ShadowWizard No, I do not. Only the upvote for the question. However, I remember upvoting the answer almost immediately after reading the Q/A because they were both very short reads. – Chris Cirefice Aug 3 '16 at 16:26
  • @ChrisCirefice hmm... So the vote is indeed not recorded. Maybe bad connection timing out, so takes a while for the error to show. – ShaWiz Aug 3 '16 at 16:50
  • 1
    you need to refresh page in browser if you want to be sure that vote was indeed recorded. I sometimes see red popup that there was error submitting a vote, it quickly disappears (so it's easy to miss, especially if you quickly scroll to next answer) but voting triangle stays colored as if it happened. Page refresh clears that and I can see that vote wasn't recorded indeed – gnat Aug 3 '16 at 17:49
  • @gnat This happens on mobile too (iOS). I guess maybe the API is just taking forever to respond with an error, but that seems really unlikely, because if there is an actual error like trying to vote on a post that is locked, the error immediately shows (both on web and on mobile). Unless there is some error deep within the voting logic that takes a long time to propagate, then that should probably be addressed... errors like voting on a locked post are a lot simpler than reputation calculation, for example, so I could see this being the problem. – Chris Cirefice Aug 3 '16 at 20:48

You must log in to answer this question.

Browse other questions tagged .