If you have never logged in to Google, for example when you install a new browser (specifically, if no Google cookies are set), and you try to log in to a Stack Exchange site using your Google account, when you click the red "Google" button, you get this message:

Suspicious request

Sorry, your request could not be completed because it looked suspicious. If you meant to perform an action on Stack Overflow, please return to the previous page and try again.

Here's a screen shot: Ubuntu log in fail

"Trying again" yields the same result.

The problem is the attempt is not "suspicious", so the message is incorrect/inappropriate. It's a reasonably expected scenario that should be catered for, probably by redirecting to the Google log in page as it does when Google cookies are set, but you're just not logged in to Google.

To repeat:

  1. Clear browser cookies
  2. Browse to a stack exchange site
  3. Click "log in"
  4. Click the red Google button
  5. The above message immediately appears

Then, to make the problem go away, change step 1. either to:

  1. Log in to Google
  2. Log off from Google

or, of course:

  1. Log in to Google

I have verified that this problem occurs on:

  • Ubuntu/Firefox
  • Ubuntu/Chrome
  • Windows 7/Firefox
  • Windows 7/Chrome
  • Windows 7/Internet Explorer
  • Windows 10/Chrome
  • Windows 10/Internet Explorer
  • Windows 10/Firefox

For completeness, other related scenarios work OK:

  1. If you have a Google account cookie set, but you're not logged in, clicking the red Google button works - you get redirected to the Google account log in page, where you can log in to Google, and then you're logged in to Stack Exchange too
  2. If you're not logged into google already, clicking the red Google button logs you in to Stack Exchange immediately
  • What browser? Are third-party cookies enabled? BTW, one of your ISPs appears to enjoy changing your IP about every other request, so I'd guess that's probably the source of the error. – Shog9 Aug 9 '16 at 19:46
  • @Shog9 this problem is not a new. I've had this happen to me a while ago using Windows 7/Chrome. This instance was Ubuntu/Firefox. I believe it's reproducible fixed IP or not. Oh regarding 3rd party, yes. I'll update the question, but once you've logged in to google before (and not deleted cookies) everything works – Bohemian Aug 9 '16 at 19:55
  • FWIW, I've never reproduced this on a stable IP - AFAIK, it's specifically caused by Google sending you back with a different IP than what you left with. If you can reproduce it on a stable IP, that'd be different. – Shog9 Aug 9 '16 at 20:02
  • @Shog9 but the problem goes away if the google cookie is set, logged in or not. – Bohemian Aug 9 '16 at 20:05
  • The process completes much more quickly if the google cookie is set. If your IP changes (say) once every 20 seconds, that's enough time to redirect to Google's auth server and back again but probably NOT enough time to type your password, wait for two-factor, etc. – Shog9 Aug 9 '16 at 20:09
  • @Shog9 I'm pretty sure you haven't understood the failure. It happens instantly. There is nowhere to type anything. If you click the red google button you instantly see the "suspicious" error message. – Bohemian Aug 9 '16 at 20:11
  • Hmm... That does seem odd that it'd work if you were already logged into Google then (unless you're just very unlucky with the timing). Regardless, I cannot reproduce without the jiggly IP thing... – Shog9 Aug 9 '16 at 20:30
  • BTW I am now continuously getting "Too many requests" page (posting this via mobile) :( I am working for Amazon in Seattle now. Maybe there is high traffic firewall weirdness going on. – Bohemian Aug 9 '16 at 20:34
  • No, that's a separate issue - sysops are testing new rate-limit thresholds. There should be an email link on that page, if you don't mind clicking it and dropping us a short note with the default subject line for our records? – Shog9 Aug 9 '16 at 20:37

Browse other questions tagged .