1

I also got this issue (which was previously closed as fixed), with a very long error message that had lots of red text overlapping other areas on the page.

This error message was observed after typing an incorrect password once, and then a correct password. Some strings have been replaced by [stringX] for privacy, and a space has been added after each protocol to avoid autolinking. I was attempting to log in with my Stack Exchange account that I was already logged into on most other Stack Exchange sites.

The return_to parameter does not have the same protocol (HTTP vs HTTPS) as the "actual URL" and the latter also has a whole lot more in parameter information.

Unable to log in with your OpenID provider:

The openid.return_to parameter (http:// area51.stackexchange.com/users/authenticate/?[string1]) does not match the actual URL (https:// area51.stackexchange.com/users/authenticate/?[string1]&openid.claimed_id=https%3A%2F%2Fopenid.stackexchange.com%2Fuser%2F[string2]&openid.identity=https%3A%2F%2Fopenid.stackexchange.com%2Fuser%2F[string2]&openid.sig=[string3]&openid.signed=claimed_id%2Cidentity%2Cassoc_handle%2Cop_endpoint%2Creturn_to%2Cresponse_nonce%2Cns.alias3%2Calias3.mode%2Calias3.type.alias1%2Calias3.value.alias1%2Calias3.type.alias2%2Calias3.value.alias2&openid.assoc_handle=[string4]&openid.op_endpoint=https%3A%2F%2Fopenid.stackexchange.com%2Fopenid%2Fprovider&openid.return_to=http%3A%2F%2Farea51.stackexchange.com%2Fusers%2Fauthenticate%2F[string5]%26dnoa.userSuppliedIdentifier%3Dhttps%253A%252F%252Fopenid.stackexchange.com%252Fuser%252F[string2]&openid.response_nonce=[string6]&openid.mode=id_res&openid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0&openid.ns.alias3=http%3A%2F%2Fopenid.net%2Fsrv%2Fax%2F1.0&openid.alias3.mode=fetch_response&openid.alias3.type.alias1=http%3A%2F%2Faxschema.org%2Fcontact%2Femail&openid.alias3.value.alias1=[string7]&openid.alias3.type.alias2=http%3A%2F%2Faxschema.org%2FnamePerson&openid.alias3.value.alias2=[string8]) the request was made with.

  • 1
    Are you using HTTPS everywhere? – Laurel Aug 21 '16 at 1:22
  • 1
    Disable HTTPS for a few minutes, and enable it afterwards. – haykam Aug 21 '16 at 1:27

Browse other questions tagged .