9

I just renewed my antivirus (Kaspersky's) yesterday.

After that, I logged onto Chemistry.SE (which I frequent often) but then I was greeted with this enter image description here

Which was definitely not how it looked like earlier that morning.

I wasn't able to

  1. Open the reputation and badges tab
  2. Vote on questions, answers and comments (even answers to MY questions)
  3. Comment on questions or answers.
  4. 'Favorite' a question
  5. Attach tags to a question
  6. Post questions

etc., etc.

But when I logged on to the Physics and Biology SEs (which I also frequent), the page format hadn't changed, but I still faced the same problems as above.enter image description here

Does anyone know how to fix this?

P.S- I'm not a computer/formatting whiz, so you'd have to try avoiding the jargon when helping me out, sorry.... (Also I use Chrome...in case that's important.)

Also @Oded recommended checking out the browser developer tools and having a look at the CSS, but as I said, I'm no Software/formatting whiz...so I'm still lost....

enter image description here

On @Shadow Wizard 's advice I've taken a screen shot of the 'error' notification (I had to scroll down to get all 10 'errors' on screen, hence the need for separate screen-shots)

enter image description here

  • Although clearly I'm able to post questions, attach tags, and do most other things on Meta.SE for some reason.......thank God...... – paracetamol Sep 1 '16 at 12:35
  • 2
    Need to figure out why our CSS is being blocked. What do your browser dev tools tell you? – Oded Sep 1 '16 at 12:36
  • 1
    The 10 errors are the cause for your problem. Click it to see what those errors are and post a screenshot. – Shadow Wizard Sep 1 '16 at 12:54
  • @ShadowWizard Just added those screenshots to the post, thanks! – paracetamol Sep 1 '16 at 13:06
  • Oh, oops. Well, that's the result not the source. The source is in the network tab of the dev tools. – Shadow Wizard Sep 1 '16 at 13:07
  • When you look at the network tab (after a refresh of the page), are any of the lines red? If so, which, and what error/s? – Oded Sep 1 '16 at 13:07
  • @Oded I put up a screenshot of those in the question (latest edit) – paracetamol Sep 1 '16 at 13:09
  • Nope, you didn't. You put up a screenshot of the console errors - I am asking for something else, in a different developer tools tab. – Oded Sep 1 '16 at 13:09
  • @Oded Alright, let me get this straight; I've got to click the network tab, refresh the page, and THEN take a screenshot ? (Really sorry for being a pain in the neck...) – paracetamol Sep 1 '16 at 13:11
  • 1
    I don't need the screenshot, but yes. Go to the network tab, refresh the page (F5). If there are any lines in red (or with a status code in the 400 or 500 range) - those are the ones we need to see. – Oded Sep 1 '16 at 13:13
  • 1
    @AaronAbraham as a workaround, try browsing https://chemistry.stackexchange.com/ instead (i.e. the secure site), if it's indeed the anti virus blocking the site, it might not block if it's the secure version. If it works, note you won't be able to visit its meta site though due to a known issue on SE side. (But that's rather minor.) – Shadow Wizard Sep 1 '16 at 13:18
  • @ShadowWizard Whoa, that WORKED! – paracetamol Sep 1 '16 at 13:22
  • @Oded Thanks as well! – paracetamol Sep 1 '16 at 13:23
  • 1
    Cheers, posted this as answer. – Shadow Wizard Sep 1 '16 at 13:37
  • @Robert not only layout is skewed, user also couldn't perform any actions requiring JavaScript. – Shadow Wizard Sep 1 '16 at 16:33
6

As a work around, you can bypass the antivirus by browsing the secure version of the site.

This works for all Stack Exchange sites and let you perform all the core actions, however HTTPS is not yet fully supported: Better HTTPS support for Stack Exchange sites

The main downside of being forced to browse the https version is not being able to log into any per-site meta (due to their sub domain), unless you add a manual security exception. For more details about that, see Ilmari's answer.

3

As Shadow Wizard notes, a good workaround for all sorts issues caused by clumsy meddling proxies, firewalls or broken antivirus software is to use Stack Exchange over HTTPS. This is pretty easy to do: just click your browser's URL bar and replace the http:// prefix with https:// (or just add the https:// prefix, if your browser hides it for plain HTTP sites).

Alas, HTTPS support on Stack Exchange is still not perfect. While it mostly works, there are a couple of remaining issues that can be a bit annoying.


One problem is that Stack Exchange is full of http:// links that will drop you back out of HTTPS mode when clicked. While most (but alas, still not all!) links in the navigation interface actually are properly HTTPS-preserving, almost all links in posts and comments will still use plain old HTTP.

One way to solve this problem is to install the HTTPS Everywhere browser extension, which will make your browser automatically use HTTPS on any sites that are known to support it, even if you follow a plain http:// URL. By default, HTTPS Everywhere will also apply to lots of other sites besides Stack Exchange; most people would consider this a good thing, but if you don't like it, it's possible to configure HTTPS Everywhere to only apply to certain specific sites.

A more limited solution is provided by the SOUP user script (which — disclaimer — I am the main author of), which simply rewrites any internal links on Stack Exchange sites to not drop you out of HTTPS mode. SOUP won't force you into using HTTPS, but it does try to keep you from dropping accidentally back into plain insecure HTTP. One limitation of SOUP is that it cannot rewrite links coming from outside the Stack Exchange network (e.g. from Google search results). To get such links also rewritten to use HTTPS, something like HTTPS Everywhere is needed.


Another problem with Stack Exchange's HTTPS support is that per-site meta sites are broken over HTTPS, giving a scary "invalid certificate" warning. This is caused by an unfortunate incompatibility between SE's site naming scheme (in which per-site metas have host names of the form meta.*.stackexchange.com) and the current standard for SSL wildcard certificates (which effectively disallows wildcards of that form). Nick Craver's blog post from 2013 explains this issue in more detail.

Nonetheless, it is in fact possible to use per-site metas over HTTPS, simply by clicking through the error message and setting up a manual security exception. On Firefox, for example, you need to click "Advanced", then "Add Exception...", and finally "Confirm Security Exception". On Chrome, you also need to first click "Advanced" (which is written in small gray letters, making it deliberately hard to notice) and then "Proceed to meta.site.stackexchange.com (unsafe)".

Of course, before doing this, you should verify that the security error is indeed just a technicality, and not someone trying to subvert your Internet security. If your browser shows the certificate as being valid for *.stackexchange.com, you can be reasonably confident that it indeed belongs to Stack Exchange, Inc.; if it doesn't, you should probably not accept it.

Ps. One unfortunate side effect of this is that, because of the certificate mismatch warnings, HTTPS Everywhere does not currently force HTTPS for per-site metas (and, in fact, will automatically downgrade any HTTPS links to them back to plain HTTP!). If you like, it is possible to manually edit the HTTPS Everywhere ruleset to remove the exclusion and downgrade rules, but this can be somewhat tricky in practice.

You must log in to answer this question.

protected by Community Dec 22 '18 at 11:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .