7

I have encountered this issue twice today; once could be a glitch, twice is ... ?

The second case concerns the poster of https://bicycles.stackexchange.com/questions/42423/what-type-of-bicycle-do-i-need-for-euro-trip-throughout-countries

At the time of posting this question, the relevant part of the question page looks like:

enter image description here

It show the user has one bronze badge.

When I visited the user's profile, it showed

enter image description here

I generally use this information to write my welcome message for new members; if they have not visited the tour page then I like to suggest that they do.

Edit

@Glorfindel suggested that it may be due to caching.

I don't think that can be the case. At least not at my end. I had never opened that page before. When writing this post, I left that page open. After asking Firefox to refresh it, it now shows the user has the editor badge.

The key evidence, I think, is the screen shot that shows "Badges (1)" and then show no badges.

  • 5
    it does say rare badges, chances are the badge they do have isn't a rare one – Memor-X Sep 7 '16 at 5:22
  • 2
    shouldiblamecaching.com - I do see a bronze badge on the user's profile. – Glorfindel Sep 7 '16 at 5:40
  • @Memor-X Yes, it shows the rarest badges if there are too many to easily fit on the page :-) – andy256 Sep 7 '16 at 6:35
  • @Glorfindel Yes, so do I, now. I have not done anything AFAIK to effect caching, and I have not seen this occur before. I'm Bicycles top first post reviewer and have been working the same way for ages: if the member seems to have badges I go and check them. If they don't have the informed badge I suggest they take the tour. So while it may be a caching issue, I strongly doubt it. – andy256 Sep 7 '16 at 6:41
  • @andy256 i always assumed it just showed the rarest and common badges like Autobiographer and Tutor wouldn't show unless you went to their activity. – Memor-X Sep 7 '16 at 6:50
  • 2
    @Memor-X The users profile now shows the editor badge; not really rare, but the only one he's got. – andy256 Sep 7 '16 at 6:53
  • I also believe this is some sort of caching, but in the very least, the count should be synchronized with that caching and show 0. – Shadow Wizard Wearing Mask Sep 7 '16 at 7:54
  • The caching does not occur on your system, but on ours. The information that is used to create the page is generally cached server-side and the only thing anyone can do to get it to update is wait. – animuson Sep 7 '16 at 15:03
  • @animuson My take on the only thing anyone can do to get it to update is wait means we goofed the design and we're not going to fix it. The UI is inconsistent, meaning wrong. An attempt to access data that's cached should still get the correct data! How long does one have to wait? How can your content suppliers (us) know that what we're looking at is correct, in order to supply correct content? It seems to have worsened lately, why is that? – andy256 Sep 7 '16 at 23:16
2

This is a bug due to (server side) caching indeed. There have been multiple posts related to 'badges that have appeared and disappeared somehow'.

There are some metrics that are updated once you earn a badge (like the badge count), but the full statistics are calculated once in a while. That might cause some delay before it is visible to you and others.

One other case of this issue that got deleted by a moderator, but which demonstrates the exact same issue can be found here.

| improve this answer | |
  • That link says Page Not Found This question was removed from Meta Stack Exchange for reasons of moderation ... – andy256 Sep 7 '16 at 14:24
  • That is because you don't have sufficient reputation to see deleted questions. Only if you have 10K+ reputation you can. – Patrick Hofman Sep 7 '16 at 14:41
  • I must have a short attention span. The first half of the last sentence in your answer said it was deleted. – andy256 Sep 7 '16 at 22:17
  • The comment from animuson♦ above shows that you're correct. Shocking to see they think it's ok to present inconsistent data. I'm waiting and hoping for a better SE response. – andy256 Sep 7 '16 at 23:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .