0

I'm aware that it is necessary to login separately on Area 51, Stack Exchange sites or Stack Overflow, etc.

I've been absent (from my PC only for about 20 days) and mostly online via my mobile app about three weeks until last Monday week. Since then even if I leave my favorite pages of Stack Exchange, Area 51, etc. open in Firefox I need to login each day (as described above) at windows shut-down.

I wonder whether this is a bug on the Stack Exchange Network or a Firefox related issue.

I hope you could help me out in both cases!

P.S. 1: Now as I tried to check my Firefox version which actually is 48.0.2, and an update (for 49.0) started!

P.S. 2: The sessions that don't work are running on a Windows 7 VM, and I tried the same on an Ubuntu 12.04 (Precise Pangolin) VM and didn't have that issue at all!

P.S. 3: Changing the cookies setting on Firefox and the update didn't make a change on Stack Exchange. I still need to re-login, and on Area 51 it worked. I didn't try on Stack Overflow, etc. so far!

  • 1
    Maybe you're browsing in Private/Incognito mode? (or has some setting that clears cookies when you close the browser.) – Shadow Wizard is Ear For You Sep 21 '16 at 7:40
  • See here, turns out it was some browser extension causing this. Try to remove all your extensions/plugins as well, see if it helps. – Shadow Wizard is Ear For You Sep 21 '16 at 8:08
  • @ShadowWizard I've made a comparison and found out that on the win VM I delete cookies after FF shut-down, but as said this setting is maybe 3 or 4 years old since I started working for the company. So this doesn't really explain why this only started happening lately. – Medi1Saif Sep 21 '16 at 8:14
  • 2
    Well, in the past SE used local storage for login, and at some point they switched to using cookies. Not very recently, think it's at least half a year. – Shadow Wizard is Ear For You Sep 21 '16 at 8:15
  • @ShadowWizard in my case the first time a faced this issue is 10 days ago. But I've been "away" for almost 20 days before that. – Medi1Saif Sep 21 '16 at 8:17
  • So really no idea, sorry. Try with different browser, different connection if you can (e.g. WiFi). – Shadow Wizard is Ear For You Sep 21 '16 at 8:24
  • 2
    @ShadowWizard I'll observe the situation now after the update and re-setting of the FF settings and give feedback. Thanks for your effort! – Medi1Saif Sep 21 '16 at 8:27
  • Let us continue this discussion in chat. – Medi1Saif Sep 21 '16 at 12:58
  • @ShadowWizard July 2015. Time flies. – Adam Lear Sep 21 '16 at 15:51
  • @Adam huh! Indeed it does. lol – Shadow Wizard is Ear For You Sep 21 '16 at 17:32
1

This is more likely a workaround:

Installing chrome as suggested by Shadow Wizard helped me out.

This would mean that the problem should be with Firefox. But until now I couldn't find major differences in the settings between the ubuntu and the win7 VM except that Firefox on the later has more add-ons like IE-Tab 2 (FF 3.6+) (is necessary for the access to the companies intranet) and Disconnect (which has been installed 5 months ago. as it seems)

|improve this answer|||||
  • 2
    Try clearing your browser history in Firefox. This used to be an issue a while back where Firefox would just stop picking up/storing cookies correctly after a while. I was never able to reproduce it myself, but folks have reported that cleaning out some of the browsing history appears to help. – Adam Lear Sep 22 '16 at 17:01
  • @AdamLear in my case even cleaning the browsing history didn't work I'll stop using firefox step by step! – Medi1Saif Sep 27 '16 at 6:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .