5

I run Firefox 49 on Ubuntu 16.04. When I enable the "HTTPS Everywhere" add-on in my browser, Stack Exchange sites stop updating automatically.

That means on the main site, I do not get the N questions with new activity banners, on questions I miss the N new answers to this question, and also the show N new comments link. My notification and reputation inboxes also don't get updated.

I assume those features use the websocket technology, please correct me if that is wrong.

All these in-site updates do not work with "HTTPS Everywhere" enabled though. Can this please be fixed?

4

We don't officially support HTTPS Everywhere, so if it breaks stuff... the best advice I can give you is to turn it off or set up exceptions for affected domains. (For sockets, that'd be qa.sockets.stackexchange.com.)

We're working on SSL support, though there's still no hard deadline/ETA for the release.

FWIW, I'm not sure why this would be breaking. We don't fully and officially support HTTPS on Q&A sites yet, true, but it should mostly work. If I visit Stack Overflow over HTTPS, all realtime notifications appear to be working fine, so I suspect the issue you're seeing has something to do with HTTPS Everywhere itself.

  • Sad to hear that, but thanks for your feedback. Looking forward to when HTTPS will finally be implemented on the SE network. – Byte Commander Sep 22 '16 at 21:30
5

This is a known issue in HTTPS Everywhere, and I have previously files a bug report on it on GitHub:

Stack Exchange (partial) breaks Firefox Web Sockets to qa.sockets.stackexchange.com

Unfortunately, there does not appear to be any way to whitelist the one domain, so the only way to have live updates is to disable the rules completely.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .