2

Edit: The issue hasn't occured anymore within the last two or so weeks, everything is now working fine again. Thanks to whoever fixed it!


I use RSS feeds to receive notifications about new questions via several tag filters1 according to custom defined tag criteria (I subscribed to the RSS feed for each filter, as found in the bottom right corner on the corresponding tag filter site in the browser).

In the recent days I have noticed that every few minutes, in each feed a large bunch of old messages is randomly marked as new. They do not appear as duplicate new entries, but are marked as unread/new with the old timestamp, although there was no new activity in these threads.
I took some sample cheks with the affected threads and there was nothing that could have triggered sending out a new RSS notification - no new answers, no new comment, not even an edit; the last activity that I could see sometimes took place several days ago.
Anyway, the feeds should inform me only about new and not recently active questions (this is how it used to work before and I made sure to include ?sort=newest at the end of the RSS URL).

The issue does not seem to be caused by my RSS feed reader (I use Bamboo Feed Reader for Firefox) - other readers receive old RSS messages from SE filters as new ones as well.
Additionally, my feed reader doesn't show old messages as unread in feeds other than Stack Exchange filters.
Also, when I view the filtered questions in my browser, everything seems alright, there are no old threads on top (neither in "activity" view, nor in "new").

This leads my to the assumption that there must be something wrong with the RSS feeds, randomly sending out old questions with no recent acitity as new feed messages.

The alleged bug is very annoying, because every few minutes I receive RSS notifications most of which turn out to be no new activity at all.

Could this please be fixed? Or am I doing something wrong? As far as I remember, everything has been working fine until about a week ago.

1These are the affected feeds:

  • Can you share a link to the feed? – rene Sep 25 '16 at 19:54
  • @rene I added them. – lemontree Sep 25 '16 at 19:58
  • I assume you refer to this question for being active without anything happening on it? Is it in this html feed – rene Sep 25 '16 at 20:10
  • @rene Yes, for example. – lemontree Sep 25 '16 at 20:11
3

That is not a bug but I understand why you think it is.

One of the examples in your feed was this question. There are no new answers, edits or comments. But something did happen which is revealed when you visit the timeline or revisions. The question was bumped by the Community User.

The Community User does this for unanswered (in the SE definition) questions. The goal is to give these question some fresh eyes so they get a chance to be answered or gather some votes.

The behavior you see is similar what users on the site will see if they watch the active tab of a tag. In that sense I believe this is by design.

  • Oh, okay. I actually thought about this possibility before, but it confuses me because the feeds should actually inform me only about new questions, while the automatic community moderator "edits" are only new activity - at least I thought subscribing to new rather than active threads would work not only for the browser but also for the RSS feed by including ?sort=newest in the URL which I did, and I can't recall having had this issue before. – lemontree Sep 25 '16 at 20:23
  • Maybe it is an regression. Let's wait for a dev to either confirm or bust my answer @lemontree – rene Sep 25 '16 at 20:25
  • Alright, thank you so far. – lemontree Sep 25 '16 at 20:25
  • Bumps are also seen in the revisions. (Better than timeline in this case, as they focus only on revisions to the questions, timeline shows much more details which in this case are not relevant) – Shadow The Curly Braced Wizard Sep 25 '16 at 20:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .