8
  • App Version: 1.6.0.10
  • Device: iPad mini 2G (Wi-Fi)
  • OS Version: Version 9.3.5 (Build 13G36)

Just updated (to 1.6.0.10) and the hot question links no longer work. They highlight as if selected but do not open the question. "Recent" question links still work.

I've tried

  • closing and reopening the app;
  • force rebooting the iPad (hold home/power until second apple logo displays);
  • deleting and reinstalling the app
  • upgrading from iOS 9 to iOS 10

No joy.

This bug does not occur on an iPhone 4s running iOS 9.3.5 and the SE app 1.6.0.10.

Prior to tapping on a hot question

enter image description here

After tapping on the leftmost hot question-note the color change but the question does not open.

enter image description here

  • Same problem with iOS 10.0.1, on an iPad Pro 9.7" – Max Oct 1 '16 at 9:06
  • 3
    This bug makes the iPad app semi-useless... Can it get some attention, or at least acknowledgement? – Ex Umbris Oct 2 '16 at 1:17
  • 2
    I also have the problem on an old iPad 2 that is still on iOS 9 (because it isn't eligible to upgrade to iOS 10). – Jonathan Leffler Oct 2 '16 at 5:09
  • @BryanNickel Any chance of getting at least an acknowledgement that this has been noted? Thanks. – Ex Umbris Oct 3 '16 at 1:10
  • Yeah, this is reaaaaally annoying:-( – Max Oct 3 '16 at 9:54
  • @ExUmbris Brian is not pingable here, he doesn't have some magic trigger on all MSE questions. – Shadow The Dragon Wizard Oct 3 '16 at 15:51
  • @ShadowWizard What do you suggest to get some attention? As the app is currently broken on iPad, I would think the developers would like to be informed. The lack of any acknowledgement is... surprising. – Ex Umbris Oct 3 '16 at 16:06
  • Have some patience, bugs get looked at but it takes time. – Cai Oct 3 '16 at 16:32
  • In case of big bugs asking in chat can also be fine. Just don't start a new room. :-) – Shadow The Dragon Wizard Oct 3 '16 at 17:30
  • I guess I will assume the bug report has been noticed by the appropriate people despite the lack of acknowledgement. @ShadowWizard I tapped the chat link you provided but it created a new room....? – Ex Umbris Oct 3 '16 at 18:53
  • @ExUmbris no you can't create new rooms just like that. You only entered an existing room that l created, and Brian got a notification. Not sure he saw it yet, he might be away for few days. – Shadow The Dragon Wizard Oct 3 '16 at 19:54
3

This will be fixed in 1.6.1.

The problem occurred when I refactored the way links are handled. Instead of sending the event from the collection view, I sent it from the model, so the event never reached the appropriate responder.

  • Any idea when this version will be released? This is a pretty major feature of the app. Thanks – Avrohom Yisroel Oct 20 '16 at 21:40
  • @AvrohomYisroel I released it an hour and a half ago. It may take a while before it appears in all stores though. – Brian Nickel Oct 20 '16 at 21:43
  • 1
    Thanks for that, I'll keep an eye out for it. Thanks for a great app, this is easily one of the best web site tie-in apps I've seen – Avrohom Yisroel Oct 20 '16 at 21:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .