8

I just received an "Enthusiast" badge on Code Review.

As much as I'd like to keep the badge, I'm certain that I did not visit Code Review every day, for 30 days straight.

Is this a bug?

I don't have the "consecutive days" stat:

No cons days

But I still got the badge:

Rep menu

And it happened again. Reported here.


Update: I just received a third badge in error; this time a fanatic badge for Software Engineering. This is even stranger, since I use that site less than I do CR, and I don't recall getting the 30 days badge.

  • Well, what if you did visit? I've been told logging in is enough. – Marshmallow Oct 8 '16 at 16:50
  • @Rubisco I open the app everyday, and visit SO. I only visit CR every 3 days; if that. – Carcigenicate Oct 8 '16 at 16:52
  • Well, what if you have a tab open or something? There's no magic involved. Or isn't there . . . – Marshmallow Oct 8 '16 at 16:53
  • @Rubisco I really only use the app, unless I need to write a long answer. – Carcigenicate Oct 8 '16 at 16:55
  • 1
    According to our logs you visited the site every day from September 9 through today (October 8). 30 days. You hadn't visited on September 7 and 8 before that. – animuson Oct 8 '16 at 17:04
  • @animuson I know I haven't visited CR all those days. I opened the app everyday, but I didn't go to CR all those days. – Carcigenicate Oct 8 '16 at 17:10
  • @Carcigenicate you have some browser plugin/extension that is responsible for this. I've seen this before, will try finding the relevant post. – ShaWiz Oct 8 '16 at 17:46
  • @ShadowWizard Kind of, except I don't use a script to check my rep. – Carcigenicate Oct 8 '16 at 18:18
  • @Carcigenicate well, something is scraping pages on your behalf and most likely this is some browser extension or even a userscript, maybe one you forgot you installed. – ShaWiz Oct 8 '16 at 19:07
  • @ShadowWizard Nope. I don't have a single extension in Chrome. Even if I did, I don't use the website directly daily. The vast majority of the time I use the app. – Carcigenicate Oct 8 '16 at 20:41
  • Well, there's always the chance the app is somehow responsible for this. I'll try asking around. – ShaWiz Oct 8 '16 at 21:29
  • @ShadowWizard It would have to be the app. I do have CR as one of my "favourite" sites on the app. Maybe it's preloading and counting that as a visit? Idk. I just know that I have no scripts on the browser or otherwise, and don't manually visit the site daily. – Carcigenicate Oct 8 '16 at 21:42
  • 5
    You guys might say that this is a dupe, but it's not! The linked OP said they used an extension to check their rep. I don't! This is clearly a separate issue related to the app. – Carcigenicate Oct 9 '16 at 10:53
  • 1
    @animuson can you please check the logs again, maybe for that other user with similar issue? Maybe the IP will give some hint... – ShaWiz Dec 19 '16 at 10:40
4

Go to your profile. (click your gravatar with reputation points at the top of the screen). Then select the profile tab.

On the right, you'll see a list of information like:

enter image description here

Now click on visited xxx days, yy consecutive. You'll see a calendar that tracks all the days you visited.

  • 1. My profile is missing "consecutive" stats. It has the rest of the information though. 2. I know I haven't visited the site 30 days consecutively. I'm reporting this as a potential bug. – Carcigenicate Oct 8 '16 at 16:59
  • 4
    Note: The calendar only shows on the full site. It doesn't show on the mobile view or the app. It also only shows to the user, so you have to be logged in. – animuson Oct 8 '16 at 17:05
  • @animuson Note the new picture I posted. I opened the full site on my mobile. Idk if it excludes the calendar even if I request the full site. – Carcigenicate Oct 8 '16 at 17:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .