5

Cooking.SE is currently a hidden community for me; I hid the community from my profile a long time ago (probably at least a year ago). When I am logged out, my user profile on the main site correctly shows only "Seasoned Advice" under the Communities section and none of my top network posts.

However, on my meta user profile on Cooking.SE, zero communities are shown under "Communities" for me when I am not logged in. (In contrast, my communities appear correctly on my meta profiles for sites I have not hidden, such as Anime.SE.) Moreover, a list of my top network posts appears. This behaviour seems inconsistent with that of main site user profiles on hidden communities.

  • When did you hide it? If only recently (i.e. recent hours) this might be just caching. – Shadow The Coffee Wizard Oct 30 '16 at 14:42
  • @ShadowWizard: don't remember when; it must have been a really long time ago. I also caught the same behaviour while browsing another user's profile, but since they (presumably) chose to hide their community (and since I reproduced the same behaviour with my account), I won't go into the specifics there. – Maroon Oct 30 '16 at 14:44
  • Thanks, maybe worth mentioning you hid it long ago in the question here, so that it would be obvious it's not caching. – Shadow The Coffee Wizard Oct 30 '16 at 14:45
  • 1
    note; status-completed here refers to the q&a vs meta oddity (fixed next deploy); the overall behavior is intended; see my answer for more info – Marc Gravell Oct 31 '16 at 13:32
1

Apparently this is intentional, as per this comment:

// If on a hidden site, we pretend to other users that it is the only community

So; on a site that you have marked hidden, we hide both inbound and outbound links. So if X is hidden, then from other sites you can't see X, and from X you can only see X. Now, there's a slight remaining oddity that from the Q&A site you can see ... the same Q&A site (like here), but on the meta site we show nothing. That appears to be a bug in the code that does this filter not quite getting the parent/child (q&a/meta) site relationship perfect - that will be fixed shortly (so the meta site can see the q&a site).

  • This makes sense; I assumed the behavior on meta wasn't quite intended, not the main site behavior. Will the issue with top network posts being shown on the hidden meta profile also be fixed, then? – Maroon Oct 31 '16 at 13:42
  • @Maroon I confess, I focused so much on the one part of the bug that I completely missed the "moreover"; reading/checking now – Marc Gravell Oct 31 '16 at 13:44
  • @Maroon I've checked, and basically: no - the network posts thing is never populated for hidden sites; when you look (logged in), it should say something like "This site is one of your hidden sites - no network posts will be displayed to others". – Marc Gravell Oct 31 '16 at 13:48
  • I do get that notice when looking (while logged in) at my main user profile on my hidden communities, but I don't when looking at my meta profile for the same. The top network posts also still show on my meta profile when I'm logged out. (I'm testing this by opening a browser session on Chrome's incognito mode, so this probably isn't a caching issue.) – Maroon Oct 31 '16 at 14:20
  • @Maroon yeah, that's a bug; I just spotted that myself when doing my post-deploy sweep, and came back to update you of exactly that! will be fixed shortly – Marc Gravell Oct 31 '16 at 14:32
  • 1
    @Maroon that should be consistent between meta and q&a now – Marc Gravell Oct 31 '16 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .