2

Looks like an intermittent issue. I couldn't update my profile page on dataSE a few hours ago:

500 error on edit profile page of dataSE

but now its working. Any explanation?

1

It very rarely happens, but sometimes this can trigger at the precise point where a new build has just finished being deployed. And I mean the window in which it's possible is extremely (fractions of a second) small. I can recall fewer than 10 times where this has happened.

I'm 99.98% certain that's what happened. But if it wasn't, then it was something else that's extremely unlikely to ever happen again (most likely due to a build).

Edit

Looks like this wasn't due to a build, but it's definitely due to something similar to that - a very random thing that's unlikely to happen again (and extremely difficult to go back and figure out).

It's definitely not the person I secretly pay to occasionally visit our data center and unplug a random cable just because it's so much fun to watch Nick Craver when that happens. Definitely not that.

  • Nope. "rev 2016.11.15.53" - last build was made 13 days before this bug happened, so can't really be the case. – Shadow The Princess Wizard Dec 1 '16 at 15:41
  • Well, there's that .. and the chaos monkey might also be on the payroll. – Tim Post Dec 1 '16 at 17:10
  • Same monkey who lost his keys. I see. ;) – Shadow The Princess Wizard Dec 1 '16 at 17:21
  • @TimPost but I do suspect there might a slightly bigger issue as my bug report is also related to app domain recycles (who are also build/deploy related). When you find the keys to the DC maybe hand them to bluefeet to investigate if Nick didn't get crushed under one of his shinny servers ... – rene Dec 1 '16 at 19:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .