7

After submitting an edit to a post directly from the edit preview screen and returning to the main Q&A view, the edit isn't visible and you're instead greeted with a banner asking you to manually reload. This is unnecessary and the view should reload automatically.

enter image description here

enter image description here


  • App Version: 1.6.2.1
  • Device: iPhone 6s
  • OS Version: Version 10.0.1 (Build 14A403)
4
  • I'm unable to reproduce this. When I edit a question or answer, the post is updated and the "Question edited" banner isn't there. I've tried the following cases: Question edit, answer edit, question edit with banner initially on screen, question edit having navigated to another screen before submitting. Commented Dec 12, 2016 at 18:10
  • @Brian maybe with a slow/bumpy connection? Commented Dec 12, 2016 at 18:21
  • Well that is strange, it was consistently happening now I can't repro either. I'll do some more test shortly and see if I can figure out what was going on
    – Cai
    Commented Dec 12, 2016 at 18:23
  • @BrianNickel Got it... only happens from the preview view
    – Cai
    Commented Dec 12, 2016 at 18:30

1 Answer 1

3

This will be fixed in 1.6.2.5.

When you press Submit, the processing gets handled by the offscreen question editor view controller. Because the editor is offscreen, there are a variety of actions that will fail if attempted. For example, if submitting has an error that requires an alert, that alert needs to come from the onscreen navigation controller.

In this case, I was sending the instruction to show the edit up the responder chain, but since the sender wasn't in the view hierarchy, it silently failed. Passing self.navigationController as the sender fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .