10

The MathJax code in Mathematics Stack Exchange doesn't render after I updated to the new version (It used to):

screenshot

  • App Version: 1.6.2.5
  • Device: iPhone 6s
  • OS Version: Version 9.0 (Build 13A342)
  • Works fine for me – Cai Dec 19 '16 at 9:37
  • I'm also unable to reproduce. Does this problem go away if you leave and return to the question? It's possible that MathJax failed to load due to network issues. – Brian Nickel Dec 19 '16 at 17:14
  • @BrianNickel I have tried refresh several times but it doesn't work. I have tried close the app and reopen too, but still failed. – Yiyi Rao Dec 19 '16 at 18:31
  • Ugh. No idea what would be causing it. I'll keep testing. – Brian Nickel Dec 19 '16 at 19:57
  • 1
    Got it, this is an iOS 9 problem revolving around a security change I adopted. MathJax is loading as HTTP and getting rejected. – Brian Nickel Dec 19 '16 at 23:51
1

This will be fixed in 1.6.3, shipping in January.

Apple is pushing HTTPS everywhere in iOS, restricting the use of HTTP in apps starting in January. I adopted the change, switching from HTTP being allowed everywhere to HTTP being allowed only in a web view. Unfortunately, iOS 9 doesn't support this setting so it went to HTTP not being allowed anywhere.

Generally speaking, this shouldn't be a problem for us. Very few images on SE are served over HTTP and all pages plus MathJax are available on HTTPS. Unfortunately, we were doing two things:

  1. Serving posts with a base URL of the question URL (sometimes derived from the site URL), which are both often HTTP.
  2. Serving MathJax from a protocol relative URL, so if the post was HTTP it was too.

This is what caused MathJax to break.

The solution I'm following is to rewrite HTTP URLs as HTTPS when loading post content and updating our protocol relative URLs to be HTTPS URLs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .