6

When mouse hover over a user with a worn hat and available usercard (Established User) then:

  • for the first time after page load you can see a double hat:

double

  • for the next time hat appears only in the usercard:

single

Same effect could be observed on the review page.

  • 2
    That's user card, not flair. – Shadow The Dragon Wizard Jan 1 '17 at 21:33
  • @ShadowWizard thanx for fix. I just realized my mistake :) And now it is possible to reproduce bug right here! – αλεχολυτ Jan 1 '17 at 21:34
  • I see it every time. Windows 7 Home Premium 64 bit, Firefox 50.1.0 – DavidPostill Jan 1 '17 at 23:56
  • 2
    That extra hat is actually the hat from the avatar... – Anthony Pham Jan 2 '17 at 0:43
  • @PythonMaster what do you mean? I don't have hat in my avatar. Here is another, better, example of the bug. – Shadow The Dragon Wizard Jan 2 '17 at 9:52
  • @PythonMaster you are right. See my diagnosis in the answer. – Patrick Hofman Jan 3 '17 at 9:54
2

This happens because initially the hat is rendered on the user avatar. Once the large user card is shown, that rendering remains, so it looks like the hat is rendered twice on the user card, which it isn't. It just sits in the background.

After the user card is sized down, the original hat on the avatar isn't used any more. The resized hat from the user card is. Hence it doesn't show the second time around.

This could be 'fixed' by removing the hat in the background when the user card is opened, not closed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .