-1

For the past couple of weeks, I've not been able to use Stack Exchange because the CSS is not loading. On Meta it works fine since they use a static CSS, but on Stack Exchange, the CSS doesn't load. I've tried using Firefox, Chrome, and IE11; I've tried clearing the cache, rebooting and clearing the cache and then rebooting. None of this has worked. I found this question on Meta that mentioned checking that the CDN is not blocked, so I went and added it to the "Trusted Sites" in my internet options. I can now load the CSS in Chrome. But in Firefox and IE11 I still get the CSS not loading. I've tried navigating directly to a CSS that is supposed to load like this one and I get an error message.

IE11 error:

This page can't be displayed

Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to https://cdn.sstatic.net again. If this error persists, it is possible that this site uses an unsupported protocol or cipher suite such as RC4 (link for the details), which is not considered secure. Please contact your site administrator.

Firefox error:

Secure Connection Failed

The connection to the server was reset while the page was loading.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.

Looking into these IE11 has the TLS 1.0,1.1,1.2 all enabled, so it's not that. I was wondering if there is anything that is not up-to-date with the CDN that Stack Exchange uses?

Firefox sends me to the Mozilla support site to check for answers. It basically says that there are methods of connection being used by the site that are not up-to-date and therefore not secure.

EDIT

I cannot find a solution to this. It works fine in Chrome, but not in Firefox or IE11. According to the answer below there is nothing wrong or out of date with the CDN. So now I'm at a loss as to what the problem is. My co-work has the same problem, except that he cannot get it to work in Chrome either. I've checked the firewall and nothing stands out to me that could be causing this (and since this is a work computer there isn't much that I could do if there was anyhow). I have checked the Anti-Virus, and again I don't see anything that would prevent the CSS from loading. I know that this started sometime last week, I don't know the exact day. I have checked everything that I can think of to find the culprit. Is there anything else that might be causing this? I am using Win7 x64 with the latest browsers (all kept up to date).

closed as off-topic by Shadow The Princess Wizard, Patrick Hofman, Glorfindel, ᔕᖺᘎᕊ, Anthony Pham Jan 3 '17 at 15:25

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The problem described here can no longer be reproduced. Changes to the system or to the circumstances affecting the asker have rendered it obsolete. If you encounter a similar problem, please post a new question." – Shadow The Princess Wizard, Patrick Hofman, Glorfindel, ᔕᖺᘎᕊ, Anthony Pham
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 5
    You mean this file? It works fine for me in all browsers, the SSL is valid until August 2019. Something on your side is messing up with your connection, check firewall, anti virus, any "security" software you might have installed, etc. – Shadow The Princess Wizard Jan 3 '17 at 14:20
  • 2
    You are accessing the site over https:// right? Do know that some corporate enterprisey firewalls are known for dropping and blocking the most ridiculous things, like html pages that contain sql statements to urls with the letters cdn in it. Try to browse to the site with your phone, or go get a coffee at a shop with wifi and use a laptop so you either confirm or rule out that specific network path. – rene Jan 3 '17 at 16:12
  • If it works in Chrome, why do you care for other browsers? Just use Chrome. – Shadow The Princess Wizard Jan 3 '17 at 16:14
  • I can use my tablet on my companies "guest" network and it loads everything just fine., but then I use chrome there too. I would like it to work on all browsers as I often have all of them open and use them for research into various topics as I'm working. If I'm restricted to just Chrome so be it, but it would be nice to have it working across the board. – Mike Jan 3 '17 at 16:48
6

No, it is not out of date. Here are the secure connection details for https://cdn.sstatic.net which hosts all the CSS files:

None of those is out of date, and all of them are considered good practice as far as I could find.

  • Although this didn't solve my problem it did point me in the right direction. I've got my Network team working to get it straightened out. – Mike Jan 5 '17 at 17:57

Not the answer you're looking for? Browse other questions tagged .