3

I am not sure if it is a problem with Google Chrome, or maybe one of the extensions on my browser.

In last month, in many cases when crawling in Stackoverflow or meta site, browser open a download dialog (or display json content) instead of the requested HTML page.

I tried searching the meta, but couldn't find a duplicate bug.

Chrome version: 56.0.2924.87 (64-bit) OS: MacOs Sierra

UPDATE1: I disabled all my extensions, and the issue is still reproducible.

UPDATE2: It is reproducible in incognito mode. I tried to reproduce it on HTTPS, and I couldn't. But since it is a random bug, I am not sure if the issue is with http

UPDATE3: no error in console. But in case that I got the download popup, I tried to see the ajax call response, and it was empty. (I try to capture an image)

UPDATE4 I tried with other browsers (FF, Safari), and there was no problem. I also tried with a few other Mac machines, and I could reproduce the bug, but not on Windows machines.

enter image description here

closed as off-topic by Nathan Tuggy, Ward, ShaWiz, Marshmallow, Nathaniel Mar 2 '17 at 15:19

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "This question does not appear to be about the software that powers the Stack Exchange network, within the scope defined in the help center." – Nathan Tuggy, Ward, Nathaniel
  • "The problem described here can no longer be reproduced. Changes to the system or to the circumstances affecting the asker have rendered it obsolete. If you encounter a similar problem, please post a new question." – ShaWiz, Marshmallow
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Does it happen when you disable your extensions? – Oded Feb 27 '17 at 22:09
  • What links cause this json content to come up? Are you browsing over HTTPS or not? – Oded Feb 27 '17 at 22:10
  • Are you seeing any errors in the browser developer tools? – Oded Feb 27 '17 at 22:10
  • So, this is intermittent? One time you click on a link, everything works as expected, another time, same link you get json? – Oded Feb 27 '17 at 22:30
  • Yes that is the case, and many others. – Afshin Moazami Feb 27 '17 at 22:33
  • Examples: (1) refreshing a page, (2) clicking on a tab/link several times, (3) opening a stackoverflow page from google result – Afshin Moazami Feb 27 '17 at 22:33
  • Even while I was commenting, I got a json object replaced with my comment (or when I was trying to upload the image). The strange thing is it happens in http not https, but even when I force the page to use https, after a few click here and there it may redirect to http – Afshin Moazami Feb 27 '17 at 22:34
  • 1
    If you truly can't reproduce when browsing over HTTPS, then chances are that your ISP (or someone else between you and us) is injecting content into the pages, causing the issue. – Oded Feb 27 '17 at 22:35
  • 2
    The fact that it only happens over HTTP strongly implies that you're a victim of a man-in-the-middle attack. Use HTTPS Everywhere or similar to force SE sites to load over TLS. – Nathan Tuggy Feb 27 '17 at 22:36
  • I will investigate that. I have two quick questions. (1) Is it normal that Google gives me the link to a http page not https? (2) Should I remove this question or answer it when I fix my issue? – Afshin Moazami Feb 27 '17 at 22:43
  • To be more accurate about the google results. If I copy the url address, it is https, but when I click it goes to http, and I will get this in the dev console: Navigated to stackoverflow.com/questions/tagged/google-app-engine – Afshin Moazami Feb 27 '17 at 22:45
  • One more case: clicking on the notifications has http by default, not https – Afshin Moazami Feb 27 '17 at 22:52
  • Since SE still does not fully support HTTPS, it's expected the Google results will point to HTTP. As for copy URL, it's Google's address, which is indeed secure, e.g. https://www.google.co.uk/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0ahUKEwj1g9vxs7LSAhWELcAKHc08DLsQFggZMAA&url=http%3A%2F%2Fstackoverflow.com%2Fquestions%2F11627279%2Frunning-java-helloworld&usg=AFQjCNELN1-DeRzha9oOg7t1DgW-gtpO0g&bvm=bv.148073327,d.bGg which when processed by Google, performs a redirect to the actual, non HTTPS, url address. (don't try to copy&paste URL in the comment, it broken due to bug) – ShaWiz Feb 28 '17 at 8:48
0

Based on the conversation in the comments, we found that the issue is happening when a page is loading in HTTP mode, not HTTPS.

Some folks believed that it should be an issue in my network and probably there is a man-in-the-middle. It makes sense to some extent because I saw similar issues on websites other than SO-family. But, it is strange that the issue does not happen on other browsers (e.g. FF, Safari)

Although I couldn't find the root cause of the problem, I fixed it with a workaround. Using a chrome extension, I forced certain domains to be redirected to HTTPS.

This solution works, but since it does not the best answer, I keep this question unanswered for further possible answers.

Not the answer you're looking for? Browse other questions tagged .