Last week, I tried to suggest an edit for a question on a Stack Exchange site on which I did not have an account. I say "tried," because the button for "improve this question" was missing. I reported the issue on that site's meta, but I don't see that anything happened.

Today, it happened again. And now I have pictures:

a question from the History site, with the area of the missing "improve this question" link circled

Why did only the English adopt, evolve and use the longbow en masse in war?

For comparison, this is what you're supposed to see.

A question with the "improve this question" link circled

What is the idea behind the touch move rule?

However, not every question on History is affected:

A different History question, with the link present

Pre-columbus, what tools did Native Americans use to shave their heads and faces?

I'm using Chrome 56 and Windows 10 (no available updates for either). The issue persisted when I opened the page in incognito mode, and also when I opened it in Firefox.

This is only the second time I've noticed it, but this bug seems to like beta sites.

PS Will someone with a History account and sufficient rep please fix the their/there error in the first sentence of the last paragraph? Thanks.

  • I noticed this before too. Here's the post.
    – Laurel
    Mar 2, 2017 at 18:10

1 Answer 1


If you had an account you would see that the "edit" link is disabled and the tooltip reads:

Another edit is awaiting approval for this post. Further edits cannot be submitted until the pending edit is reviewed.

So, basically, there's already a suggested edit (probably the thing you wanted to fix) and until that's processed you can't suggest another edit. I'd approve the edit, but I don't have enough rep on the site to do reviews.


Not the answer you're looking for? Browse other questions tagged .