2

The SE android app crashes when tapping on red-underlined text (by the spellcheker).

To reproduce:

  • Start writing a comment
  • Insert some gibberish, something like "fjghsdfggo", followed by a space
  • Tap the gibberish word you just typed
  • Crash !

Here's a GIF showing the problem:

Screenshot

...And here's the logcat:

E AndroidRuntime: FATAL EXCEPTION: main
E AndroidRuntime: Process: com.stackexchange.marvin, PID: 9528
E AndroidRuntime: java.lang.UnsupportedOperationException: Failed to resolve attribute at index 6: TypedValue{t=0x2/d=0x101009b a=1}
E AndroidRuntime:   at android.content.res.TypedArray.getColorStateList(TypedArray.java:528)
E AndroidRuntime:   at android.text.style.TextAppearanceSpan.<init>(TextAppearanceSpan.java:65)
E AndroidRuntime:   at android.text.style.TextAppearanceSpan.<init>(TextAppearanceSpan.java:45)
E AndroidRuntime:   at android.widget.Editor$SuggestionsPopupWindow.setUp(Editor.java:3316)
E AndroidRuntime:   at android.widget.Editor$PinnedPopupWindow.<init>(Editor.java:3016)
E AndroidRuntime:   at android.widget.Editor$SuggestionsPopupWindow.<init>(Editor.java:3309)
E AndroidRuntime:   at android.widget.Editor.replace(Editor.java:356)
E AndroidRuntime:   at android.widget.Editor$3.run(Editor.java:2129)
E AndroidRuntime:   at android.os.Handler.handleCallback(Handler.java:751)
E AndroidRuntime:   at android.os.Handler.dispatchMessage(Handler.java:95)
E AndroidRuntime:   at android.os.Looper.loop(Looper.java:154)
E AndroidRuntime:   at android.app.ActivityThread.main(ActivityThread.java:6126)
E AndroidRuntime:   at java.lang.reflect.Method.invoke(Native Method)
E AndroidRuntime:   at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:886)
E AndroidRuntime:   at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:776)
W ActivityManager:   Force finishing activity com.stackexchange.marvin/.ui.BaseActivity

I'm running the latest beta version of the app from the play store, on Android 7.1 (Cyanogenmod). In other apps, the suggestions popup does work correctly, so it seems to be something with the way the SE app does it that doesn't seem to work. IIRC, it did work correctly on older versions of Android, so maybe a change in Android ?

  • I've never find such trouble. It may be issue with cyanogen mode. – Pandya Mar 11 '17 at 14:30

You must log in to answer this question.

Browse other questions tagged .