5

I assume this is something to do with the big HTTPS change ...

Just now I was fixing up some broken images on meta sites by changing http to https. Many of these were on pro-tem mod nominations, which often include the main-site, meta-site, and network flairs of the nominee. But for some reason, the meta-site flairs aren't working.

For example, https://scifi.stackexchange.com/users/flair/31394.png works to give this image:

My SFF user flair

but https://scifi.meta.stackexchange.com/users/flair/31394.png doesn't display an image at all:

My SFF meta user flair - failed

(In case anyone else isn't seeing the same error, here is what I see for this post.)

I've also tried http://meta.scifi.stackexchange.com/users/flair/31394.png (gives the now-usual "must use HTTPS" error) and https://scifi.meta.stackexchange.com/users/flair/31394.png (doesn't work at all, or at least gives the same non-functioning image as meta.scifi).

What gives?

8
  • 1
    HTTPS has never worked on meta sites. The transition forcing flairs to be HTTPS broke them on Meta. This will be fixed when they change the meta sites to be HTTPS too. – Tim Mar 12 '17 at 13:32
  • Both display fine for me: i.stack.imgur.com/L0C0R.png. For what it's worth, I'm on latest Opera and using HTTPS everywhere (maybe it's relevant). – Gallifreyan Mar 12 '17 at 13:34
  • @Tim It's very odd: posts with HTTP images on meta look fine (they haven't devolved to "alt text + link" like on main), but when I go to edit any such post, the "HTTP images don't work" error box still comes up. – Rand al'Thor Mar 12 '17 at 13:35
  • meta.scifi.stackexchange.com/users/flair/31394.png works for me as well. – Gallifreyan Mar 12 '17 at 13:40
  • @Gallifreyan Is that an HTTP link or an HTTPS link? I can't tell from your comment. – Rand al'Thor Mar 12 '17 at 13:44
  • Comment stripped the http part, but both work for me. – Gallifreyan Mar 12 '17 at 13:45
  • 1
    Possible duplicate of HTTPS issue on meta, but no issue on main – Optimus Prime Mar 13 '17 at 9:28
  • @SagarV That question itself is a duplicate of a duplicate of this feature request from 2011. My question is much more specific than that one. – Rand al'Thor Mar 13 '17 at 22:21

You must log in to answer this question.

Browse other questions tagged .