13

Why do I see a Spanish blog post in the Community Bulletin module across the Stack Exchange network?

enter image description here

While I appreciate the multilingual approach to Stack Overflow, my Spanish is only good enough to order something in a restaurant, not to read blog posts. I guess this is the same for most users here. I'd like to have links to non-English blog posts not appear in the Community Bulletin – if an exception is built in for (in this case) es.SO (and maybe spanish.SE), that's fine.

  • imgur support seems to be broken at the moment. If you can't see the image, look at the yellow block at the right side of this page. – Glorfindel Mar 14 '17 at 20:50
  • @AdamLear are you sure it's a [bug]? – Glorfindel Mar 14 '17 at 21:02
  • Yes. Something got overlooked in the last blog system migration. Not 100% sure what, but this is a regression from how international blog posts were working before. – Adam Lear Mar 14 '17 at 21:03
  • OK, thanks. I usually don't pay attention to blog posts, so I don't know how the system is supposed to work. – Glorfindel Mar 14 '17 at 21:05
  • 2
    Unless you use one of the international SO sites, you had no way to know we had these blog posts for a long time now. :) – Adam Lear Mar 14 '17 at 21:06
  • No, I don't, except for flagging spam. – Glorfindel Mar 14 '17 at 21:06
8

Sorry about that. We recently moved our company blog to a different hosting platform (again!), and that caused some issues both with in-English posts being sync'd to community bulletins on localized Stack Overflow sites and with non-English posts written by community managers on those sites being propagated to community bulletins network-wide.

A fix is out in production now, though community bulletins are cached. They should self-heal in a few hours. Please let me know if you see any other CB weirdness after that.

  • Is the new hosting platform WordPress? Looks like it from reading the source, but you were supposedly migrating away from it... – user315433 Mar 15 '17 at 2:47
  • 5
    @NormalHuman So, funny thing about that... Turned out that WordPress is a massive pain to maintain and host on-prem for us given the low activity on community blogs, but is actually pretty alright for non-technical contributors. I'm not up on all of the details, but as far as I know we ended up with hosting at a third-party provider who takes care of the infrastructure maintenance for us and consolidating company blogs from Jekyll and Hubspot into one location. – Adam Lear Mar 15 '17 at 2:58
  • Or in short, we should expect many more bugs. – Shadow Wizard Mar 15 '17 at 14:46
  • And now it appears in the Tavern. Same bug? – Shadow Wizard Mar 22 '17 at 21:43
  • can we get an rss feed that does not include these for blog.so? Because having a bot regularly post these into a site main-room is just begging to ignore the bot, even when the post would be relevant ... – Vogel612's Shadow Jun 5 '17 at 17:43
  • 1
    @Vogel612'sShadow Maybe! I'll talk to the folks running the blog to see what's possible there. – Adam Lear Jun 5 '17 at 18:07
  • 1
    @Vogel612'sShadow The main blog feed should exclude non-English posts now. – Adam Lear Jun 28 '17 at 20:43
  • @AdamLear thanks very much :) – Vogel612's Shadow Jun 28 '17 at 21:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .