8

I tried to mod-migrate a question from meta.sf to here but I encountered an issue where I can't select meta.stackexchange.com as a target.

If I select any "normal" site like "stackoverflow", "super [user]" etc., everything works as expected, but when entering "meta.stacke", I end up with a partial list of all sites starting with numbers or the letter A, but without the SE Meta in the list.

enter image description here

I've tried this with Firefox on macOS Sierra and Ubuntu 16.04 and Chrome on macOS.

  • Looks like most of the meta sites are missing off that list, not just MSE – ChrisF Mar 18 '17 at 19:33
  • @ChrisF: It appears to only include sites starting with the letter A and numbers (3D printing being the only one). – Sven Mar 18 '17 at 19:34
  • I guess this is something to do with the recent HTTPS carnival. – Rand al'Thor Mar 18 '17 at 19:37
  • For me, Meta Stack Exchange comes up if I start entering "Meta S" in the field (on Mathematics main and meta). Is it a picky input format or doesn't that work either on meta.sf? – Daniel Fischer Mar 18 '17 at 19:42
  • @DanielFischer: Thanks, that worked for me. But still, I believe this used to work like I tried it, but since this migration direction is so rare on Server Fault, I am not really sure about it. – Sven Mar 18 '17 at 19:46
  • 4
    Could be due to the change from meta.<sitename>.szackexchange.com to <sitename>.meta.stackexchange.com. Thus the URL-part meta.stackexchange.com now matches a boatload of sites, too many for the popup to display, while before it only matched this one. – Daniel Fischer Mar 18 '17 at 19:50
  • Adding [ssl] because I suspect this has to do with the HTTPS migration – ArtOfCode Mar 18 '17 at 19:59
  • @DanielFischer - I tried both "meta Stack..." and "Stack..." and got he same results as Sven, I also managed to get an "undefined" as a single entry in the dropdown. – ChrisF Mar 18 '17 at 21:13
  • @ChrisF You should have migrated to "undefined", for science. I'd be curious what error that pops up. – Daniel Fischer Mar 18 '17 at 23:02
  • Tried following your steps, can't reproduce. – Oded Mar 22 '17 at 14:16
  • @Oded: Hmmh. Tried again on more browsers, Safari on macOS Sierra, Firefox, IE and Edge on Win10, all with the same result. – Sven Mar 22 '17 at 14:57
  • I'll try again - did you check the developer tools for errors? – Oded Mar 22 '17 at 15:07
  • Tested with 4 different browsers - getting the correct results :/ – Oded Mar 22 '17 at 15:13
  • I see what I did different - I searched for the site name - "meta stack" - no . - I don't think domain search ever worked here. – Oded Mar 22 '17 at 15:17
  • @Oded: Try to migrate to apple.st as an example, it will show "Ask Different", so it works for other sites. I believe that Daniel's explanation is spot on. In the end, it's not really serious anyway, as there is a working way to do this migration. – Sven Mar 22 '17 at 15:28
3

We recently moved all child-meta domains to a <sitename>.meta.stackexchange.com to help with our move to HTTPS.

This does mean that when you search for meta.stackexchange.com, all child metas are returned - as their URLs contain that fragment. The autocomplete only populates the top 10 results, which doesn't include Meta Stack Exchange.

I don't see how we can fix this, given that the autocomplete should not return exact matches.

The work around is to drop the dot - searching for meta stack will give you far fewer results, including Meta Stack Exchange.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .