25

Over at Science Fiction & Fantasy, I answered this question: Why did Voldemort choose a snake as a Horcrux given that it is a living thing and has a limited lifespan? (spoilers for Harry Potter 6/7!). This brought my reputation up to 10,565. However... this upvote didn't show up in the dropdown. Some screenshots:

The dropdown, showing +120 today:

dropdown

My ?tab=reputation page, showing +130:

reputation tab

My /reputation page, showing the upvote:

/reputation page

So...

Why is it not showing in the dropdown?


This also happened with another answer - the dropdown is exactly the same as before, and yet I gained another 10 rep, and it's showing in all the other places. And on this question - there's no change in the dropdown. And again on SO - I had a suggested edit approved, which gave me +2, and... nothing in the dropdown.

  • One more case: Just I joined a new community, the association bonus is not listed in the Recent achievements popup. – Arulkumar Mar 30 '17 at 8:36
  • 5
    I think someone screwed up a deployment. I get the same thing on magento.stackexchange. – Marius Mar 30 '17 at 9:01
  • Things got stuffed between 07:15 and 07:45 UTC today (see my duplicate report at Achievements dropdown no longer updating). – Martijn Pieters Mar 30 '17 at 9:09
  • Same. Can't see them on SF&F either – NSNoob Mar 30 '17 at 10:21
  • 1
    Update from Oded over on MSO: We are aware of things being broken - the process that syncs reputation (and other things) across the network is backed up. We are working on fixing it. – Martijn Pieters Mar 30 '17 at 11:40
  • I did get notified about my Marshal badge, though... – user58 Mar 30 '17 at 11:46
  • 1
    Badges work, rep not. – Patrick Hofman Mar 30 '17 at 11:47
  • Apparently, it's partially fixed. I get notifications for new reputation changes, though previous ones (that were broken) are still missing from the dropdown. – Panda Mar 30 '17 at 12:22
  • I just ran into this now with a post here on MSE (rep change occurred 10 minutes ago, does not display in achievements), desktop site. Rep change is shown in reputation section of profile activity page, just not in the achievements drop down and no notification icon appeared. – Jason C Mar 30 '17 at 17:56
  • This happened to me today on Worldbuilding. – Monica Cellio Mar 30 '17 at 19:43
10

There was a serialization issue that caused our messaging pipeline to stall - a few times.

There was a mismatch between serialized objects, which was throwing exceptions when trying to send messages. Specifically, cached old objects wouldn't deserialize to the new object structure.

We have cleared out all the offending messages and bolstered the code to handle such errors better (including changes to how these work locally so we catch them long before they get to prod).

Sorry for the inconvenience.

  • I just noticed a similar issue today, posted it on meta and was directed to this question. Is it the same issue, or is there something else going on? Thanks. – orthocresol Apr 2 '17 at 14:02
2

Yes. The process is up and running again. Reputation changes are finding their way to us.

Sometimes there is a small delay though in the dropdown and the green notification. And the number doesn't always correspond with the highlighted post in the dropdown. I guess that will be resolved eventually.


Update 14:48 GMT: The process seems to have stalled. I didn't receive any updates on recent votes, so I guess there is an issue.

Update 07:00 GMT: All seems to be okay now again. All reputation changes seem to come in directly after the actual event.

  • @NSNoob I guess that is old. Those have been processed indeed. Recent votes are not visible yet. – Patrick Hofman Mar 30 '17 at 13:54
  • Probably, I came back to my computer about 19 mins ago and I had received rep change of +35 from a question. Admittedly it was sum of whole rep change which was received today, not just new ones so you might be right. – NSNoob Mar 30 '17 at 14:12
  • I posted an answer since you wrote this, and the 30 rep I've got from it so far still hasn't shown up in the dropdown. – Rand al'Thor Mar 30 '17 at 14:23
  • Indeed. Broken again. – Patrick Hofman Mar 30 '17 at 14:31
  • @randal'thor Can you confirm it works again? – Patrick Hofman Mar 31 '17 at 7:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .