Asking questions on Stack Overflow stopped working today. I click the button to submit - it turns grey, but nothing happens.

I am using Firefox 3.0.15 on Ubuntu and have been posting question on stack overflow regularly for a while. Tried clearing the cache.

Also tried it on another computer downstairs running Windows 7 with Firefox 3.5. Still failed. Also failed when I tried Internet explorer:-(

I went to university, tried posting a question with Firefox 3.5 on Windows XP. Doesn't work. What the heck?

I tried asking a question with adding a new tag - perhaps this has something to do with it?

From a comment by the OP:

Sorry, the title was too short. I think I didn't see this because I'm too used to error messages being in red rather than gray

  • Interesting, I can ask on meta – Casebash Nov 11 '09 at 6:01
  • Can't give an answer. (Joking) – Andrew Grimm Nov 11 '09 at 6:45
  • 1
    Ctrl+F5? Safe Mode? Updating browser? – Ladybug Killer Nov 11 '09 at 8:26
  • This happened to me a while back on superuser.com, so I ended up asking my question on stackoverflow.com and asked people nicely to help me migrate it. – Dominic Rodger Nov 11 '09 at 10:40

Try a different browser to see if you can repro it. I can't.

edit: make sure you're looking at the error messages next to every single field. I think you're missing something here. No repro, no other reports of this for any users in the world.

If no SO users anywhere in the world could post questions -- or even if a small fraction of them couldn't -- I think we might know about that by now. Just sayin'.

| improve this answer | |
  • I saw some stuff earler - see my answer. – Marc Gravell Nov 11 '09 at 21:57
  • Sorry, the title was too short. I think I didn't see this because I'm too used to error messages being in red rather than gray – Casebash Nov 13 '09 at 3:11

My vote: dodgy javascript (corrupt or incompatible-cached):

  • some moderator flags that I processed kept coming back when I refreshed the screen (i.e. they'd only been removed in the app's imagination)
  • attempting to post a comment just reloaded the question page
  • attempting to expand the "close" reasons did nothing

I emptied the browser's cache, and all is now well. Try that. It could have been the team's javascript, or it could have been jQuery etc; we may never know...

| improve this answer | |
  • Sounds unlikely considering the number of browsers/computers he tested it on. Also, all JavaScript file paths appear to have version numbers attached to them, which should prevent caching of old scripts (unless someone forgot to update the version number). – Blixt Nov 12 '09 at 11:44
  • @Blixt - all I know is: for a while things didn't work very well fox me... – Marc Gravell Nov 12 '09 at 12:41

This is a long-shot... but do you have Firebug for Firefox or some other tool that can monitor requests sent by your browser? It could be that something is interfering with the HTTP requests sent by the JavaScript, causing them to fail or time out. This would explain why you get the same behavior in all browsers.

The strange thing is that it's only for stackoverflow.com... perhaps your ISP/router is filtering or redirecting something related to that domain somehow?

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .