3

Regarding How to install SQL Server 2008 Express with Inno Setup?, I just had a comment posted saying it was incomplete. And it was.

Thing is, I'm pretty sure it was complete when I posted it, and here's another interesting thing.

There were links in the answer that still worked but, when I went into edit mode, the links were not at the bottom (the square bracket thingies) and the preview showed just the text for the links (double square bracket groups), not the HTML links themselves.

Now, I don't particularly care about the answer itself, I've edited it to get rid of the code since we ended up testing the Microsoft-blessed solution and it was fine, so there was no need for the hacky workaround.

I'm just raising this for the powers that be in case they want to investigate. I live in mortal fear of all the information I've pumped into Stack Overflow over the last year just up and disappearing on me :-)

1
  • Had you put some whitespace at the and of your post? That could fix the issue. Commented Nov 11, 2009 at 14:21

4 Answers 4

0

I live in mortal fear of all the information I've pumped into SO over the last year just up and disappearing on me

Don't live in mortal fear. Download the Creative Commons Data Dump for SOFU and burn it on a DVD. It is relatively simple to import the data into a database or (for one-offs) to write simple scripts to extract the required information.

1
  • 1
    agreed, that's one reason we do that... rest assured you work will NOT be lost. Commented Dec 7, 2009 at 0:39
1

At first I thought it was the same as this issue:
https://meta.stackexchange.com/questions/12988/serverfault-cut-off-truncated-on-long-post

However, this is something different. In all the other posts, the entire contents are visible if you view the source or edit history and you can fix the post to show all the data with a simple no-op edit (add a space somewhere). It looks like the missing content really did vanish.

0

That is odd -- it looks like the data is truncated in both fields (raw markdown and cooked html) in the original post. From our database's perspective, it never arrived.

https://stackoverflow.com/revisions/527117/list

Random's example is a bit .. random .. since there's no repro or artifact, just an anecdote.

If you can reproduce it, let us know.

4
  • There was no way jjnguy didn't write the bulk of that referenced answer that might have been lost. It was all there on the rendered page, but the edit chose to truncate it out to one paragraph.
    – random
    Commented Nov 11, 2009 at 23:02
  • I'd be quite happy to believe that it was never there but for one small point. The text starts with "[This page][1]" has has no "[1][link]" at the bottom so it renders that as text rather than a link. However, when I first looked at the answer after being told it was truncated, the links were there and they worked so that information must have been stored somewhere (unfortunately, that's probably anecdotal evidence as well since I've edited the answer). I'll keep my eyes open for a re-occurrence. Thanks, guys.
    – user14860
    Commented Nov 12, 2009 at 0:04
  • As noted, another example found: meta.stackexchange.com/questions/29324/the-sky-she-is-falling/…
    – random
    Commented Dec 6, 2009 at 14:36
  • @random not the same thing; any migrated question is suspect due to a historical bug in the question migration code. AFAIK the original question we're no-repro-ing was NOT migrated. Commented Dec 7, 2009 at 0:38
0

In the original version of the accepted answer to Accepting answers, what is it all about? the entirety of the text was there.

But on editing to include the image of plain sight, the edit window only contained about one third of the original text.

The revision list of that particular post illlustrates better. The only actual edit made by random to that post was adding in the image and yet it looks as if he added in a massive bulk. No whey there.

The eventual edit luckily happened only after this realisation and no loss of the answer was suffered.

Another find: To those who can edit, what do you see in the edit box when you try to update the accepted answer on the Voting limits FAQ?

The same content, I see in the revision list. Very weird, indeed. Smithers

2
  • Overlooked that about the revisions list.
    – random
    Commented Dec 6, 2009 at 14:53
  • 2
    As this is a migrated post, I think I know why. The migration code originally had a bug in it -- it didn't fully migrate the correct version of posts; there was a discrepancy between the cooked (rendered html) and raw (markdown, revision history) versions of the post. Commented Dec 6, 2009 at 16:39

You must log in to answer this question.