15

In Firefox and IE, I'm seeing this bug on all main SE front pages:

scripting error

It's showing docsHero.RenderPartial(Html); storyHero.RenderPartial(Html); on the top of the front page.

  • I thought it's only for the Devops site! Also, had the screenshot ready for a Meta post :D – Dawny33 Apr 6 '17 at 18:28
  • Same on The Workplace. – enderland Apr 6 '17 at 18:29
  • It doesn't appear on some subpages (e.g. /questions/) but I'm encountering it on the main page of all sites... but not meta :) – Erica Apr 6 '17 at 18:29
  • 7
    Yeah, copy/paste fail when refactoring some view logic, and that only shows up some of the time :/ Pushing a fix in a moment. – Michael Stum Apr 6 '17 at 18:30
  • @MichaelStum Thanks! – called2voyage Apr 6 '17 at 18:31
  • 1
    Rolled back to the previous build, then double, triple and quadruple checking the view. Still looking at what happened, but basically, it's a banner that isn't always shown, so I didn't see it and it doesn't always show for everyone. Sorry about that! – Michael Stum Apr 6 '17 at 18:34
  • 1
    Properly fixed it and rolled out the latest build again. Hero working as expected again – Michael Stum Apr 6 '17 at 18:44
  • 1
    @Michael buy a beer to all of us and you shall be forgiven. :D – Shadow Wizard Wearing Mask Apr 6 '17 at 22:44
  • 4
    @ShadowWizard In the spirit of "Give a man a fish", I have something even better than giving a beer: An entire site dedicated to making your own beer! homebrew.stackexchange.com – Michael Stum Apr 6 '17 at 23:08
  • @ShadowWizard or post an appropriate question at DevOps.SE about best practices to prevent such "production problems" (hint 1: "four eyes" hint 2: "representative test data" ... hint 1234: "the best test is in production, and just rollback if it doesn't seem to work as intended"). – Pierre.Vriens Apr 9 '17 at 19:00
  • @Pierre heh, sure'y Michael is well aware of all these. This just proves we are all humans. :-) – Shadow Wizard Wearing Mask Apr 9 '17 at 19:14
  • @ShadowWizard sure we're all humans, but it also proofs that SE has some serious DevOps challenges (our should I say "business opportunities"). My favorite "challenge" to SE, whenever these kinds of oeps-cases show up: "Which QA-environment does SE have available to have their end-users QA-review the suggested change, prior to moving it to production"? ... And if there is such environment, "where are the proofs of your test-results"? – Pierre.Vriens Apr 9 '17 at 19:30
  • @Pierre big changes go through this very site first, and/or Meta Stack Overflow which is even bigger in scale and users. That's their test ground. As for this specific glitch, it was just a small mistake, and all in all no harm done. :) – Shadow Wizard Wearing Mask Apr 9 '17 at 19:45
3

Yeah, copy/paste fail when refactoring some view logic, and that only shows up some of the time :/ Pushing a fix in a moment.

Rolled back to the previous build, then double, triple and quadruple checking the view. Still looking at what happened, but basically, it's a banner that isn't always shown, so I didn't see it and it doesn't always show for everyone. Sorry about that!
– Michael Stum♦

So everything is fixed now. Yay! :P

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .