2

On some SE sites, I get some whitespace on top of the topbar. It looks like this:

whitespace

Inspecting the CSS I find the rule

body, .so-header {
    margin-top: 1.9em;
}

If I disable it, the whitespace is gone:

no whitespace

Some observations:

  • This only happens on the beta sites, not SO or meta.
  • This is browser specific, the screenshots are from Firefox 52. (Epiphany and Midori working as expected)

Update: I found where the CSS was located, it is in a noscript element:

<noscript id="noscript-css"><style type="text/css">body,.so-header{margin-top:1.9em}</style></noscript>

I am indeed blocking google-analytics, quantserve and scoreboardresearch.

stackexchange.com is allowed through though, so why would you want to show me this white bar?

  • No Repo on SpaceEx.Ex with Windows 10 - Chrome v57.0.2987.133 (64-bit) or Firefox 52.0.2 (32-bit) even after wiping out cache. odd thing is that when looking in the developer tools in firefox and chrome for the body i see no CSS like that since body, .so-header is supposed to apply to both <body> and class="so-header" elements. you don't have any addons that can add/alter css do you? – Memor-X Apr 17 '17 at 23:18
  • @Memor-X Exact location of the CSS and context added. – Hohmannfan Apr 17 '17 at 23:27
  • quoting W3Schools (please don't brick me) "The <noscript> tag defines an alternate content for users that have disabled scripts in their browser or have a browser that doesn't support script.". when i disable Javascript in firefox i get this and the css appears so i say that you have scripts disabled in the first screenshot but somehow didn't have the message show up – Memor-X Apr 17 '17 at 23:31
  • @Memor-X Disabling javascript completely indeed causes that warning to show up for me as well. – Hohmannfan Apr 17 '17 at 23:36
  • do you have any text in that bar when it's white like that? it might just look empty since the text colour is white (though it would be odd, text and bg colour are specified in #noscript-warning) – Memor-X Apr 17 '17 at 23:41
  • @Memor-X There is no text in the bar. The rendered document has no node located there, it is just a margin, and telling Firefox to dump all the text from the page to a document does not have it either. – Hohmannfan Apr 17 '17 at 23:48

You must log in to answer this question.

Browse other questions tagged .