4

Equations are not rendered in MathJax on any of the SE sites. I can only see that the markdown. Here's a screenshot -

screenshot

I tried the steps given here, restarted my computer too. JavaScript is enabled in settings too. I'm using Google Chrome on Windows 7. What is causing MathJax not to load? What can I do to make it right?

I had asked a question regarding the same here but I've since deleted it due to downvotes(and I accept that it was my fault).

19
  • 1
    If nothing is working, it's quite possible that the problem is further on down the line with your ISP or CloudFlare's servers, in which case all you can do is wait until their DNS refreshes. There's really not anything we can do to help you with this.
    – animuson StaffMod
    Apr 22, 2017 at 6:10
  • 1
    Do you use any browser extensions that block JavaScript? The site switch to a different CDN for MathJax and you might have to whitelist the new CDN domain. Apr 22, 2017 at 6:39
  • @peter I have an extension of tampermonkey which I use to print the answers on SE. But it was working finely about a week ago. Apr 22, 2017 at 6:47
  • 2
    The change was about a week ago. It's always a good idea to debug by disabling all extensions and reactivating them one by one. Apr 22, 2017 at 7:28
  • @PeterKrautzberger I tried that too. Apr 22, 2017 at 11:57
  • Have you tried another browser? Apr 22, 2017 at 16:00
  • What shows the "network" tag in your javascript debugger?
    – peterh
    Apr 22, 2017 at 23:59
  • @peter I tried Chrome, Firefox and IE. But nothing didn't work. Apr 23, 2017 at 6:01
  • 1
    @peterh I don't know what you are talking about. I'm not a computer expert. Apr 23, 2017 at 6:02
  • @ApoorvPotnis It is probably not a browser problem, and also not an SE problem. It is a problem probably in your local network. Your computer somehow doesn't get the IP address of the site from which the MathJax is downloaded from. If you are at home, restart your router. Alternatively, there are also alternate solutions, they are more tricky, you can also manually insert its ip address into the C:\Windows\System32\drivers\etc\hosts file (in windows). Probably it is solved until now.
    – peterh
    Apr 24, 2017 at 2:37
  • @peterh I restarted the router, opened the file hosts using Notepad(run as administrator, like shown here) but something weird in Chinese language showed up. I tried to change the font it won't work.(I don't understand Chinese) Apr 24, 2017 at 4:26
  • @ApoorvPotnis There shouldn't be any Chinese, only English, even on non-English Windowses. Probably you have a virus. Trashing the hosts file was only a side-effect of the infection.
    – peterh
    Apr 24, 2017 at 5:04
  • @peterh Thanks, replacing the hosts file with text from here worked. I can now see the equations clearly. Apr 24, 2017 at 7:45
  • @peterh Maybe you could write that comment into an answer so that I could accept it. Apr 24, 2017 at 7:46
  • 1
    @AlwaysConfused Replacing the hosts file solved the issue. I can now see the equations. May 19, 2017 at 14:53

2 Answers 2

3

It is probably not a browser problem, and also not an SE problem. It is a problem probably in your local network. Your computer somehow doesn't get the IP address of the site from which the MathJax is downloaded from. If you are at home, restart your router. Alternatively, there are also alternate solutions, they are more tricky, you can also manually insert its ip address into the C:\Windows\System32\drivers\etc\hosts file (in windows). Probably it is solved until now.

About the Chinese text in your this file: In this file, there shouldn't be any Chinese, only English, even on non-English Windowses. Probably you have a virus. Trashing the hosts file was only a side-effect of the infection. Alternatively, it is also possible that some file corruption happened on your machine on unknown reasons (typically, sudden poweroff causes it).


As you write, replacing the hosts file from here solved the problem.

2

I just had this issue. In my case, it was because I had DNSSEC enabled in Pi-hole and the IP address of cdnjs.cloudflare.com (which hosts MathJax) could not be looked up as it got a "BOGUS (RRSIG missing)" status. Reverting DNSSEC to its default disabled state solved the issue and is not a major loss because unfortunately 90% of DNS entries are not signed anyway.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .