4

So this has been going on for about a week. I'm not receiving notifications of comments directed at me on the Android app. Sometimes the red square over the notification counter does appear on the app, sometimes it doesn't, but I never receive a system notification, so it doesn't make my phone vibrate, etc.

This happened after I uninstalled and reinstalled the app because it didn't detect that I was logged in, so I couldn't vote on anything, edit my own comments, etc. The uninstall fixed that problem but introduced this one. I tried reiterating to no avail. Since this started happening I've installed an android system update, which I was hoping would fix the problem, but it did not.

I have version 1.0.89 of the app and a Samsung Note 5 with Android 7.0.

  • Any chance you can downgrade to android 6? Might be the issue, as the app most likely was never tested under any newer android version. – Shadow Wizard Apr 23 '17 at 7:03
  • @ShadowWizard to be fair, the app works normally on Nexus 5, Android 7.1.2. Anyway, have you checked the in-app notification setting? Especially the "Quiet hours"... – No Distraction Wizard Apr 23 '17 at 7:56
  • I've not had issues with android 7, and I'd have noticed if anything had gone wrong since all I use it for is notifications :( – Journeyman Geek Apr 23 '17 at 9:20
  • @Shadow I don't think that's the issue, had the same problem on android 6. – Matt Samuel Apr 23 '17 at 13:07
  • @Elephant Notifications are on and quiet hours is off. – Matt Samuel Apr 23 '17 at 13:09
  • I had this problem too. The app is not much easier to navigate than the mobile web and I can see only one thing at a time, so I kept the app in the hopes that the notifications it gave would be a redeeming point. I went into the settings, made sure I had checked to get system notifications, and I didn't get them. I've tried this on two phones: one was Android 6.0, and the other is 5.1. – zondo Apr 23 '17 at 14:16
  • @zondo This is totally new for me though. It's been working fine for the most part for many months. – Matt Samuel Apr 23 '17 at 16:43
3

This happened to me recently too, shortly after reinstalling the app. Logging out and then back in again (in the app) took care of the problem.

(Same version of the app, Android 7.1.1)

  • Just tried that, hopefully it'll work. Thanks. – Matt Samuel Apr 23 '17 at 19:03
  • Well, did it work? – Shog9 Apr 24 '17 at 21:56
  • Indeed. That's why I accepted the answer. Thanks. – Matt Samuel Apr 24 '17 at 22:11
1

I don't know if this applies as I'm using an older version of Android (5.1), but here's my first thought: you mentioned in-app notifications (open app -> Settings -> Allow notifications) are on and quiet hours are off. There is also a third area where Android may silence notifications.

In the main menu/app listing screen, touch and hold the stack exchange app and drag up to 'App Info'. The following screen will show, which has another 'Show Notifications' option that overrides in-app settings:

App info

  • It doesn't look like that for me, but I verified that this option has been set. Zero notification for the answer. – Matt Samuel Apr 23 '17 at 16:42
  • This is by default enabled. If that's the problem, it would have to be because the OP explicitly turned it off. – zondo Apr 23 '17 at 20:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .