7

I am using the iOS app (iPhone 6S, iOS 10.2.1, app version 1.6.4) and I navigated to the formatting sandbox meta question and was scrolling down and when I got to the 9th answer and saw some spoilers, I tapped on them to reveal the content and started to scroll again only to have the app crash. I tried it 10+ more times with the same result.

Edit: I've also encountered the same problem on this post as well, though I haven't been able to find a consistent reproduction scenario for this question. It seems that sometimes only 5 posts are loaded and it runs into a similar problem. I don't know if it is the same bug, but in trying to reproduce the bug on this question, I have showed all the spoiler and managed to scroll down to the 5th post, however I was not able to load the next 5 answers.

Below is a picture of how far I can scroll before it crashes.

enter image description here

Okay, I did a bit more testing, and edited one of the higher voted posts (edited several others as well, had the same results, so I rolledback the edits) to have a spoiler to see if it position of the answer mattered at all. I showed the spoiler on it and scrolled to the bottom, and there was no crash and the next answers loaded fine. Though if I do the reveal the spoiler in the 9th post it still causes a crash.

14
  • CNR, iPhone 5, SE app v1.6.4.
    – ave
    Commented May 1, 2017 at 2:05
  • Weird. I have 100% reproduction rate so far. 10+ times in a row. I have an iPhone 6s with same app version.
    – Dragonrage
    Commented May 1, 2017 at 2:08
  • (Oh also, I'm on iOS 10.3.1)
    – ave
    Commented May 1, 2017 at 2:18
  • Does it happen on or after the tap-to-reveal? Like, if you tap and wait (without scrolling), does the app crash? Does it crash immediately upon attempting to scroll? Or does it happen once the spoiler text leaves the screen and you can scroll a little bit - so long as the spoiler doesn't leave the screen?
    – Robotnik
    Commented May 1, 2017 at 6:43
  • @Robotnik the crash won't happen if I don't scroll after tapping the reveal. It happens when I scroll down part way through the spoiler and I can see part of the next post. I'll upload a picture of how far down I can scroll to.
    – Dragonrage
    Commented May 1, 2017 at 6:49
  • @Dragonrage - cool. I was just hoping to nail down the exact cause to make it easier for the SE devs :)
    – Robotnik
    Commented May 1, 2017 at 6:52
  • @Robotnik no problem. I did also notice one weird time it didn't crash when trying to get the screen shot. I was scrolling very very slowly and taking screen shots periodically once I got near the crash place, and I was able to get to the bottom of the next answer without it crashing, however I couldn't navigate or scroll to the next 5 answers. I have not been able to reproduce this yet with 20+ tries. It just crashes every time I try to reproduce that scenario.
    – Dragonrage
    Commented May 1, 2017 at 6:58
  • @Dragonrage - Fair enough, what about scrolling back up? Also good pickup on the tag btw, I didn't even realise it didn't encompass the iOS version. I've now fixed that up so the tag encompasses both :)
    – Robotnik
    Commented May 1, 2017 at 7:03
  • @Robotnik scrolling back up works fine, and if I don't show the spoiler, I can scroll through all of the 15 non deleted answers. It doesn't load all 15 answers initially and it seems like it is loading the next answers about where it is crashing. Also, on the tag is it better to have one tag for both apps, or separate tags for each app, as bugs could be isolated to one version.
    – Dragonrage
    Commented May 1, 2017 at 7:09
  • 3
    Looking at the logs, it looks like for whatever reason, this exact question configuration was triggering the iOS app's most exotic, longest lived, and hardest to reproduce bug. Basically, updating the table view that backs the question list silently fails at some point and the app crashes when the system realizes its two internal representations differ. My mac is in the shop right now but when it's back I'll try recreating this scenario to see if I can get a consistent repro. Commented May 1, 2017 at 18:43
  • 1
    @BrianNickel interesting. Let me know if you want me to test anything from my end. I'm happy to help.
    – Dragonrage
    Commented May 1, 2017 at 18:49
  • @BrianNickel did this get fixed? i happened to be looking through some of m old questions and found this and tested it again, and have not been able to reproduce the crashes
    – Dragonrage
    Commented Mar 20, 2018 at 23:36
  • @Dragonrage This bug is my white whale. I've never been able to consistently reproduce it or figure out where the defect is that causes it. It causes 2 crash reports a day except on certain posts at certain moments when it generates a dozen. I've just come to live with it. Commented Mar 20, 2018 at 23:42
  • @BrianNickel i know the feel. some bugs seem to have no logical reason for happening. if i find another instance where i can reproduce it consistently ill update this.
    – Dragonrage
    Commented Mar 20, 2018 at 23:47

0

You must log in to answer this question.

Browse other questions tagged .