3

In the Edit Profile & Settings -> Preferences, under the Newsletter section, the URL for the see an example newsletter is still as http:// only. Clicking on the link it opens a blank popup window.

There is a same kind of issue was reported for the side bar and it was fixed. In the same way it need to be updated with https:// in the Edit Profile & Settings tab.

This issue is in the all of the Stack Exchange sites edit profile.

Screenshots for reference:

Newsletter link

Clicking on the link, it opens a blank popup screen.

Blank Example newsletter

Receiving the following errors in the browser console:

Google Chrome Version : 58.0.3029.110 (64-bit)

Mixed Content: The page at 'https://meta.stackexchange.com/users/preferences/current' was loaded over HTTPS, but requested an insecure resource 'http://stackexchange.com/newsletters/newsletter?site=meta.stackexchange.com&suppressPromotion=true'. This request has been blocked; the content must be served over HTTPS.

Mozilla Firefox : 54.0b13 (32-bit)

Blocked loading mixed active content “http://stackexchange.com/newsletters/newsletter?site=meta.stackexchange.com&suppressPromotion=true

You must log in to answer this question.

Browse other questions tagged .