37

A few very weird things are going on.

First I noticed on this question that when I hovered over the tags, "edit tags" appeared on the next line, and so was unclickable:

enter image description here

As I was reporting that I found it was already reported here, at least for long tag names. But then on that question I noticed the same thing happened for even short tags. Then, this happened:

enter image description here

As you can see, after a while, the wily user card, fearing for its life, quickly makes its escape from the window.

I can consistently make this happen but I'm not entirely sure how. I believe it's related to the "edit tags" thing (which is an issue in itself) I noticed I also need to move the mouse at least once towards the "edit tags" link. Then, it's when moving the mouse between tags that the user card starts to move.

I can consistently make this happen by moving the mouse back and forth between a tag and an attempt at "edit tags". After some number of times, the user card starts moving. This also happens on posts with a single tag.

(And actually, looking at my first gif above, I'm also realizing the user card thing happened there, too, which I didn't notice when I first recorded that.)

The behavior depends on the browser:

  • Chrome 58 (Windows): The above happens.
  • Opera 43: The above happens.
  • Firefox 53 (Windows): The "edit tags" is on the next line but the user card does not move.
  • IE 6, IE 11, Edge (Windows): "Edit tags" is in its correct place on the right and there are no issues.
  • 1
    I just came here to post about the same problem. I saw a Q&A earlier today about changes to site CSS and formatting, so this may be related – Midavalo May 19 '17 at 16:29
  • @Midavalo You mean this one? Yeah I thought the same thing. – Jason C May 19 '17 at 16:34
  • Yes, that was the one I was referring to. I'm sure the edit tags link was to the right rather than underneath previously, so something has changed here. – Midavalo May 19 '17 at 16:37
  • 1
    I can add that the user card moves in Chrome, but not in Firefox. The edit tags link is underneath and almost impossible to click while using both browsers. – Midavalo May 19 '17 at 16:39
  • Additionally, on IE11, the edit tags link is in its correct place on the right and there are no issues. – Jason C May 19 '17 at 16:43
  • 2
    no repro ie6 win me – Won't May 19 '17 at 16:53
  • 1
    No repro Edge, either – Won't May 19 '17 at 16:54
  • @Won't Is "edit tags" on the right on Edge? – Jason C May 19 '17 at 16:55
  • Just popped up on MSO. – Jason C May 19 '17 at 17:07
  • 1
    @JasonC proper functionality has been established on Edge. Opera 43 is also boned. – Won't May 19 '17 at 17:20
  • Not to hijack your question, but what means "runs for dear life"? I understand each of those 4 words, but not the combination of them. I doubt I'm not the only one "who didn't learn English on his/her mother's knees", and doesn't understand it. Am I close with this research result (before posting this comment)? – Pierre.Vriens May 19 '17 at 18:17
  • 2
    @Pierre.Vriens It's a colloquialism where when you do something "for dear life", you do it with as much effort as possible and usually to avoid any danger. "Dear life" in the sense that we treasure our lives "dearly". So when you run for dear life, it usually happens to escape a dangerous situation. Not just running, but any action that results in your survival... running, clinging onto something, etc. – rayryeng May 19 '17 at 18:18
  • merci @rayryeng it seems from your help that I can "trust" my reserach result then. – Pierre.Vriens May 19 '17 at 18:20
  • @Pierre.Vriens Oui bien sûr! – rayryeng May 19 '17 at 18:21
  • @JasonC merci (also) ... And despite the risk that some comments get deleted (via moderation), "I" will not suggest an edit. Though feel free to reuse anything of my first comment "as a courtesy to anybody who suffers ESL, like me" (no credits due). – Pierre.Vriens May 19 '17 at 18:33
18

First: awesome title. I hope you file as many bugs as possible.

This is a subtle bug we missed in testing. In order to pin the footer to the bottom in most modern browsers, we added the following styles earlier today:

html {
  height: 100%;
}
body {
  min-height: 100%;
  .flexbox();
  .flex-flow(column nowrap);
}
.container {  
  width: 100%;
  .flex();
}

That went pretty well overall, but it turns out the flexbox has a quirky interaction with jQuery. Here's the JavaScript for the hover (mouseover so it works on the parent):

jLinkWrapper
  .mouseover(function () { jEditTagsLink.show(); })
   .mouseout(function () { jEditTagsLink.hide(); });

For some reason, jQuery changed from .show() making than <span> (which contains "edit tags") from display: inline; to display: block with the flexbox styling applied.

I'm not exactly sure why this happens (anyone know?) but a quick fix is rolling out now. Instead of .show(), it's explicitly .css('display', 'inline') now.

This fix will hit all sites in the next few minutes.

  • 1
    Borderline heat stroke fuels all good titles. – Jason C May 19 '17 at 18:16
  • 1
    @JasonC - I thought that was large amounts of alcohol? – Oded May 19 '17 at 18:19
  • 1
    This answer reminds me about Gerald Weinberg's famous quote: "If builders built houses the way programmers built programs, the first woodpecker to come along would destroy civilization.". I'm tempted to post a question related to this answer on DevOps.SE, i.e. something like "How can DevOps reduce the risk of runs for dear life?" ... – Pierre.Vriens May 19 '17 at 18:52
  • 8
    So it turns out that a flex parent blockifies children... And jQuery uses a temp element created under body to figure out what the default display value should be in cases where it doesn't have a saved value. Which it doesn't, because it starts out hidden. – Shog9 May 19 '17 at 18:56
  • @Shog9 so it's jQuery's fault? – Shadow The Curly Braced Wizard May 19 '17 at 19:13
  • 2
    The cause of, and the solution to, all rendering problems @Shadow – Shog9 May 19 '17 at 19:38
  • Should the bug from the question linked in the OP be considered status-completed, too? (I tried a few questions, but I was not able to reproduce it now.) In the other words, is "edit tags" now always displayed on the same line - and is it "easier to catch"? – Martin May 21 '17 at 9:25
  • @Martin Not sure. That bug only really manifests when the tags take up the width of the post content. The example questions in the question linked in the OP (say that 10 times fast...) no longer have that, so hard to tell. – Adam Lear May 22 '17 at 16:17
  • @AdamLear Yeah... it is hard to tell; the closest I got was this, which is still weird, but no matter how hard I tried I wasn't able to get all the tags to fit in a way such that "edit tags" was on the next line but none of the tags were (I tried a lot of tag combos to no avail). They wrap in strange ways. So while that's weird, there wasn't a situation where "edit tags" was impossible to click. Dunno. That's a lot of tag, though. Hubba hubba. – Jason C May 22 '17 at 21:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .