7

This question already has an answer here:

I encountered a bug while reviewing Suggested Edits. I clicked Improve to improve the edit and then I accidentally clicked Save Edits before I changed anything. To my surprise, I got no error message and Community♦ approved the edit and it said that I edited it (although I didn't make any changes, I just clicked the Save Edits button):

enter image description here

However, since I didn't make any actual edit, it's not visible that I made an empty edit, it only says that the user who suggested the edit edited the post:

enter image description here

I also tested to see if it did the same thing with Reject and Edit, so I tried to review a bad suggested edit as Reject and Edit and then click Save Edits without changing anything. That worked as it should, so I got an error message when trying to submit the empty edit:

enter image description here

I think that it would be good if such an error message also shows up when a user tries to submit an empty edit after clicking Improve.

marked as duplicate by Shadow, Community May 22 '17 at 13:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Browse other questions tagged .