5

I read this but this one is way back 2014 and supposed to be adding https:// will work. But as what I also read from here that https:// was already implemented thus, I already have https:// in my web browser's url field and it is labeled as "Secured". When I checked the dev tools I've got a bunch of errors like: Failed to load resource: net::ERR_INSECURE_RESPONSE and Uncaught TypeError which is basically because some js failed to load.

I'm under a corporate proxy and what confused me, this error happen randomly. Sometimes it pop-up, and after like 30 minutes or an hour it disappear and the site works normally. I tried clearing the cache, updating the browser, restarting the browser and the whole pc(sometimes it returns to normal, maybe because the error disappear randomly?) but it still goes the same sometimes.

The error shows in Chrome browser, I can't test Firefox because somehow it refuse to connect to our corporate proxy. I'm using IE10 to post this one.

It happens to all the sites, except Area51, maybe because of Aliens?

EDIT: AREA51 has errors too, it's just that the error banner don't appear

According to Ilmari Karonen, I should try to paste the url ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js, yes I can access the js file, but if I place https before the url I get the error:

Your connection is not private

And under the advanced I get this:

ajax.googleapis.com normally uses encryption to protect your information. When Google Chrome tried to connect to ajax.googleapis.com this time, the website sent back unusual and incorrect credentials. This may happen when an attacker is trying to pretend to be ajax.googleapis.com, or a Wi-Fi sign-in screen has interrupted the connection. Your information is still secure because Google Chrome stopped the connection before any data was exchanged.

You cannot visit ajax.googleapis.com right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.

Screenshot Chrome Dev

closed as off-topic by Nathan Tuggy, animuson May 22 '17 at 18:56

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be about the software that powers the Stack Exchange network, within the scope defined in the help center." – animuson
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Next time this happens, try pasting the URL ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js (or whichever URL is giving you the ERR_INSECURE_RESPONSE error) directly into the address bar and pressing enter, and see what the error page (assuming you get one) says; don't forget to click the "Advanced" button for more info. It's possible that your corporate proxy is messing with your HTTPS connections somehow, causing this error. – Ilmari Karonen May 22 '17 at 18:17
  • yeah, forgot to mention that. I read it from the previous posts comments. I get no error in that. I can access(view) the js file in the browser after I pasted it just now. – threeFatCat May 22 '17 at 18:21
  • BTW it still happening right now. I'm using IE10. This is the time I'm only thankful to IE. – threeFatCat May 22 '17 at 18:24
  • I'm voting to close this question as off-topic because it appears to be about a misconfigured corporate proxy or firewall. – Nathan Tuggy May 22 '17 at 18:53
  • As Nathan suggests above, this is clearly a problem with your corporate environment. Google is telling you as much in that error, where it's basically telling you "this is not what we expected to get from this domain." I've gotten the same type of error when trying to access sites from hotel Wi-Fi where they redirect all requests to their standard login screen before you can do anything. There's nothing we can do about it because the problem is not on our side. – animuson May 22 '17 at 18:55
  • @NathanTuggy Is it possible to experience https:// issue to stackexchange sites but not gmail? or other sites using https:// connection? – threeFatCat May 22 '17 at 18:59
  • @threeFatCat: Almost certainly, depending on the weird details of exactly how your proxy does its stuff. – Nathan Tuggy May 22 '17 at 19:00
  • that would be fine, by just now the error disappeared in the chrome and the site returns to the normal functionality. My concern was it just happened randomly. Thanks for the feedback then. – threeFatCat May 22 '17 at 19:01

Browse other questions tagged .