12

Since the beginning of the year I have not once seen a ad displayed on any SE site, including SO (yes I'm aware goofs happened). I know the ads are served somewhat randomly (looks random anyway), but in previous years I could F5/reload a page 10 times and get a community ad at least once. Now I don't even know how many times I tried, and not once have I seen any of the community ads on SO or Code Review... or any of the sites with paid ads.

Ads that do get served:

  • Paid ads (Microsoft, IBM, etc.)
  • SO Jobs ads
  • SE network / "Recent Hot Question from some SE site" ads

Either something is broken, or I'm very, very, very unlucky.

I can see that ads appear to get clicks, but knowing that a click on the ad post counts as a click on the ad, I can't tell if these clicks come from the meta post or if they're actual clicks.

Are community ads broken?

(If not, then why am I not seeing them?)

6

The short answer: no. From 1 January through today, Open Source ads received over 32 million impressions. So these ads are serving.

The long answer: no, they're not broken, but something is definitely amiss. I'm not seeing the ads on plenty of sites, which is not the expected behavior. The delivery figure mentioned above applies only to the 14 sites listed below:

  • Android
  • Arqade
  • Ask Different
  • Ask Ubuntu
  • DBA
  • Drupal
  • Game Dev
  • Software Engineering
  • SalesForce
  • Security
  • SharePoint
  • Unix & Linux
  • Web Apps
  • WordPress

I'm continuing to explore this issue further, and working with others internally to get this fixed soon. I'll post any relevant updates below.

As always: thank you for bringing this to our attention!


Update 5/24/2017
Rolled out a fix that will get Open Source ads up and running again for the following 8 sites:

  • Raspberry Pi
  • Magento
  • GIS
  • Electrical Engineering
  • Blender
  • Code Review
  • Super User
  • UX
| improve this answer | |
  • Thanks! I'm not clear exactly what that list of site means though... Can't wait to hear what's up with Code Review community ads! – Mathieu Guindon May 23 '17 at 22:25
  • 5
    BTW "not broken, but doesn't work as intended" wouldn't fly on Code Review ;-) – Mathieu Guindon May 23 '17 at 22:25
  • 1
    The list is the list of sites I'm currently tracking delivery on. Anything not there is a mystery as-yet-unsolved. – stevvve May 23 '17 at 22:26
  • Lay that list next to the list of sites you have less than 200 rep on. Is it the same list by chance? – Mast May 23 '17 at 22:43
  • @Mast actually... I do see ads on Software Engineering, where I have ~700 rep. Seems my first impression was off. In my defense I'm on CR or SO 99% of the time I spend on SE,...and the odd HNQ I click on takes me to a page where I'd typically see network-wide ads, which might have skewed my perception a little... but something's not right anyway. – Mathieu Guindon May 23 '17 at 22:50
  • 2
    I suppose you guys must be tweaking stuff, I just saw a community ad on Code Review... except it came from android.se's meta! – Mathieu Guindon May 24 '17 at 4:16
  • @Meta'sMug Ahhhhh spotted the error causing that one. Added 8 more to the list of active, correct open source promos running. I still can't track down exactly what's going on with the sites that don't currently receive paid ads, but hopefully I can get that resolved soon. Thanks again! – stevvve May 24 '17 at 14:49
  • Hmm, I just got "help this community grow" android.se ad on code review again... blame caching? – Mathieu Guindon May 24 '17 at 15:00
  • @Meta'sMug That and I'd give the ad server a little while to catch up, I just updated the ad code in there about 10-15 minutes ago. – stevvve May 24 '17 at 15:01
  • @Meta'sMug I've seen your ad being displayed on SO, a few days back. (I've seen my ad as well: i.stack.imgur.com/x6pVR.png). – Bhargav Rao May 24 '17 at 15:34
0

On Drupal.SE these ads are still showing, for sure. At the time I write this answer, on the list of newest questions the one that is showing is this specific ad (disclosure: I ever posted that ad ...).

After about 12 additional refreshes, the very same ad is shown again (no simiular ones in between).

On Drupal.SE I also see other types of ads which I assume are paid ads, so there seems to be at least 1 such site with paid ads (as in your question).

| improve this answer | |
  • Aye. 2 refreshes and I've seen a community ad and a MS Azure ad. Looks like it's only affecting a small subset of sites... no idea which ones though, but CR and SO for sure. Thanks for the counter-example. – Mathieu Guindon May 23 '17 at 19:19
  • I'm pretty sure that the other ads you refer to are not in fact paid for. The only ones I could see were Hot Network / Area 51 ads, which are not paid for externally. They fall under the "community-ads" category. I'm also pretty sure that Drupal was not added to the "select sites" in the initial announcement of more sites displaying ads .... – Vogel612's Shadow May 23 '17 at 19:22
  • @Vogel612'sShadow I doubt SE is advertising Microsoft for free ;-) – Mathieu Guindon May 23 '17 at 19:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .