6

When I leave a site's chatroom, I used to get redirected to the site rooms of my parent site (previously Hinduism.stackexchange.com now Movies.stackexchange.com).

The following used to be the redirecting link while leaving a chatroom

https://chat.stackexchange.com/?tab=site&sort=active&host=chat.hinduism.stackexchange.com

But now, when I leave a chatroom, it redirects to

https://chat.stackexchange.com where it shows only chat room.

Why did the change happen? I am sure it's not because of change of parent site in chat.

2
  • 1
    I suspect it's because you browse the https version of the chat, while chat still does not fully support https. Try replacing https with http when in chat, and see if that helps. Jun 6 '17 at 7:17
  • Thanks @ShadowWizard. Yes. It is showing site rooms now. Will you add it as an answer? But why doesn't chat support https? Is changing to http the only solution available? Because, when I click on chat, it has https by default.
    – Nog Shine
    Jun 6 '17 at 7:48
4

As far as I can tell, this happens because the link is generated based on referer header, which is not available if browsing chat using https, since chat rooms are still not supporting https.

If you will manually change the URL to http:// instead of https:// in the chat lobby/room, it will work.

The actual bug here is having links to https:// version of the chat from the sites, which happens due to using relative links and not absolute, but that's better be reported as a different bug.

Adding HTTPS support to chat is the last stage of Network-wide HTTPS: It's time, and I'm afraid it might still take a while.

4
  • So, Should I report that links from main sites are https?
    – Nog Shine
    Jun 6 '17 at 8:50
  • @SS. yes, until chat is fully HTTPS, all the links from within SE must be to http:// version of chat. Jun 6 '17 at 8:53
  • I'm now being forced to HTTPS when I use HTTP with chat. Is that on my end or SE's? Jun 30 '17 at 2:52
  • @MonicaCellio huh, it is new... Took less time than I expected. Probably Nick will update the main post soon. :) Jun 30 '17 at 8:53
0

Yes, as pointed out by Shadow Wizard the issue looks because of the problem with https::// in chat.

Until the issue is solved, I found couple of work-around:

  • Just click on the address bar to have a typing cursor and press Enter, you'll find site rooms. (Note that reloading page doesn't work for me)

  • Just use middle click instead of left click of mouse -- I mean open link for "leave" option in new tab and proceed further from new tab, you'll find site rooms.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .