2

When tapping the new mobile chat UI with the Apple Pencil on the new iPad Pro 12.9" on Safari, Apple Pencil appears to register a UI event that the mobile chat interface isn't expecting, because in several cases, the Apple Pencil does not seem to do anything on the mobile chat interface.

The expected behavior is that the mobile chat interface should treat a single tap by the Apple Pencil as equivalent to a one-finger tap.

For instance:

  1. Tap on a message -- works to bring up the bar at the top of the screen to decide what to do with it, but when tapping, say, the reply arrow or the star, nothing happens. Touching the buttons with my finger works.

  2. Tapping the chat input text box at the bottom of the chat works with both finger and Pencil.

  3. Scrolling works with both finger and Pencil.

  4. Dismissing notifications (such as the "You are now using the new mobile chat interface" notification) is extremely fiddly with the Pencil but eventually works if you're persistent (took me about 10 tries). I tried with my finger on another notification and it's much easier to click "remove notification".

  5. The "sandwich" menu in the top-left doesn't work with the Pencil, as far as I can tell. Maybe the iPad is registering it as a click and drag or something, but I tried hard to do a direct "tap" and not a tap-and-drag.

You must log in to answer this question.

Browse other questions tagged .