2

Recently Google Chrome no-more showing any icons on the visual editor tool bar. On some SE sites (Other browsers unaffected)

Screenshots:

Biology SE

biose.

Chemistry SE

chem se

Physics SE, Bioinformatics SE, etc.


However some other Stack Exchange sites are working nicely, such as:

Meta.stackexchange.com,

enter image description here

english.stackexchange.com

enter image description here

etc. ie only some of the sites being affected.


How to fix this bug?


System information:

Desktop PC, OS: Windows 7 Ultimate.

-----------------------------------------------------------------------

Updates:

As @Rene asked;

Network tab on an affected site, Bio SE Network tab on Bio SE

Network tab on an unaffected site, SE Meta Network tab on META

(To get larger view, click on image or open them on new tab)

As @Oded asked, no; it is home computer, single, currently running with airtel 3g-4g dongle. And though antivirus being used (would I must disclose?) no "add-blocker" being used.

The link you mentioned, ie. cdn.sstatic.net/Js/mathjax-editing.en.js?v=c776bb8c2bac, i clicked; and it brings to an webpage containing some commands.

The code is quite big to copy-paste; some portion is like below:

"use strict";StackExchange.mathjaxEditing=function(){function e(){m.disabled=!0,g.resetEquationNumbers()}function t(){m.disabled=!1}function
... "SVG":{"EqnChunk":10,"EqnChunkFactor":1}}),b?a(b,"Typeset"):void 0});var k,y=/(\$\$?|\\(?:begin|end) ... var n=e.processError;e.processError=function(i,r,a){return i.message!==t?n.call(e,i,r,a):(MathJax.Message.Clear(0,0),r.jaxIDs=[],r.jax={},r.scripts=[],r.i=r.j=0,r.cancelled=!0,null)},e.Cancel=function(){this.cancelTypeset=!0}}}();

some portion trimmed as ... ; only first portion, middle portion and end portion shown.

----------------------------------------------------------

Update: As @rene asked; I've uploaded screenshot of "security" tab of developer/inspect column.

View when https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.1/MathJax.js (mentioned in my answer) is not loaded.

mathjax not loaded

View when https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.1/MathJax.js has been loaded in another chrome search tab, and then again the stackexchange page reloaded.

when MathJax loaded

Though it tells "active content with certificate error", not the button "view certificate" shows any certificate error. However on the inspect/developer column of https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.1/MathJax.js shows a certificate error.

Mathjax page with certificate


As well, as @Rene asked; I'm very sorry to say I'm having to use a pirated version of windows (though I'm not really a supporter of this practice). Currently I'm unemployed and my current personal income is too little to buy an original version of windows and ms-office. Also when we bought the computer; we were novice about software installation, and all the software mechanics / technicians we met ever, were (are) too critic to proceed about original versions. :( Sorry, I'll must buy the original product whenever it will be possible in future.

So incidentally, I don't update windows. (However I don't browse to random sites, and don't download any patch or plugin etc from any third party source. )

  • 2
    If you open the developer console in your browser (usually F12, then the console tab), so you see any errors when the page is loading? – animuson Jul 30 '17 at 19:13
  • @animuson Yes, showing. On "troubled" branches I'm getting 3 erors. (1) MathJax.js Failed to load resource: net::ERR_INSECURE_RESPONSE. (2) cdn.sstatic.net/Js/mathjax-editing.en.js?v=c776bb8c2bac:1 Uncaught Uncaught ReferenceError: MathJax is not defined at cdn.sstatic.net/Js/mathjax-editing.en.js?v=c776bb8c2bac:1 at cdn.sstatic.net/Js/mathjax-editing.en.js?v=c776bb8c2bac:1 (3). beacon.js Failed to load resource: net::ERR_INSECURE_RESPONSE. Whereas on "non-troublesome" page, only one error is showing; the third one. – Always Confused Jul 30 '17 at 19:37
  • In the networktab of the dev console can you find MathJax there and shoe us what is says: this is mine working result: i.stack.imgur.com/h2fD9.png – rene Jul 30 '17 at 19:45
  • Do you have an ad blocker installed? Are you possibly on a corporate/university network that might be blocking these? What happens when you try to access cdn.sstatic.net/Js/mathjax-editing.en.js?v=c776bb8c2bac directly? – Oded Jul 30 '17 at 19:46
  • Your "anti virus" is likely messing with stuff and blocking things it considers "harmful". Disable it and it would most likely solve your issue. – Shadow The Curly Braced Wizard Jul 31 '17 at 10:49
2

I have figured out a solution; but I am still not very sure whether it is the solution or it is co-incidental. Seems everything happened within chrome's or Google's own privacy features. (However I need not change any antivirus settings, as well antivirus settings changes did no improved.)

As I was looking the developer ("inspect") tab's network page; there was a button ASK. (shown in black circle).

ASK

Now, on clicking this ask button; I was brought to a command or script page; where a command was shown with yellow highlight.

On clicking ask after clicking ask

When hovering the mouse pointer over the yellow-highlight-marked line, it was showing "Insecure_Response" (Not screenshoted).

I copied the link ( https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.1/MathJax.js )from the line, and pasted it on chrome's address bar. After hitting enter; it shown a page with a red coloured triangle containing an exclamation .

"Your connection is nor private" Back to safety.

Privacy Error

On the page, I used the "Advanced button" and selected "proceed to ... (unsafe)".

Just after hitting that "proceed" button; on other chrome tabs containing troubled branches; icons on the visual tool bars appeared suddenly. But "https" with a green lock icon got changed into a red lock button with a "striked out https".

Striked out HTTPS co occur with icon

Whatsoever; icons are thus now available; and disappears again if I clean the cookies and history.

  • 1
    When you have that unsafe connection to cloudflare.com can you again on the dev console go to the tab Security and then screenshot that as well. Just a quick check: Your Windows 7 box is up to date in regard to security patches and other Windows Update required patches? – rene Jul 31 '17 at 14:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .