32

I’m able to copy-paste from any application to any application. I’m able to copy from a comment or from a question or from an answer. I’m able to paste to a question or answer. However, if I attempt to paste into a comment, nothing happens. I am able to subsequently paste into another application, confirming that the text is actually on the clipboard.

However, copying SE links will paste them successfully, but all other text - including other links - still fails. This leads me to believe that it’s a SE issue and not an Apple one.

This has been an issue since 11.0 beta and persists through iOS 12.2 beta.

  • 1
    Reproduced on an iPad Pro running iOS 11 Beta. – Glorfindel Aug 16 '17 at 20:57
  • iOS 11 Beta? – Meta Bug Wizard Aug 17 '17 at 4:57
  • @iBug Yes, beta. Hence the first paragraph of my post. – DonielF Aug 17 '17 at 13:23
  • 1
    Seeing this on latest iOS 11 beta (using the beta version of the SE app.) – miken32 Sep 6 '17 at 2:54
  • How did you test it? For instance I can drag-n-drop links and text from the Chrome into the SE app comment section in Split View mode. – αλεχολυτ Sep 26 '17 at 6:54
  • 2
    @alexolut I didn’t say drag and drop. I said copy and paste: highlight text, then tap “copy,” then tap into a comment field and tap “paste.” (Like I said in the OP - I’m on an iPhone and therefore don’t have drag and drop.) – DonielF Sep 26 '17 at 17:02
  • @DonielF oh, now I see. Upvoted! – αλεχολυτ Sep 26 '17 at 18:30
  • Reproduced in 11.0.1 release iPhone 6S. I can paste the copied text into other apps – mplungjan Sep 28 '17 at 18:20
  • I can reproduce it: can’t paste into comments anything that is not a SE link after the update to iOS 11 on iPhone – jfs Oct 8 '17 at 6:19
  • 2
    Reproduced. iOS 11.0.6, iPhone 6. When I paste into answers, the original font style, spacing and font size get preserved, it looks pretty horrible and doesn’t affect markdown. – Narusan Nov 1 '17 at 7:54
  • Reproduced on 11.2 beta. Updated to reflect that. – DonielF Nov 6 '17 at 18:28
  • 7
    Any chance of fixing this annoying and long standing issue? – mplungjan Nov 10 '17 at 10:18
  • 1
    @mplungjan no, the app development has been frozen, the only iOS developer reassigned to different role within Stack Overflow. We won't see this fixed in the near future. (That is, years.) – Shadow Wizard Nov 14 '17 at 10:10
  • @ShadowtheHedgehogWizard This bug has existed for a long time now, so I'm just wondering if your last comment is some sort of 'official' update? That is, is it likely we really have to wait years for this to get fixed, or...? – Monomeeth Jan 3 '18 at 12:02
  • 1
    @ShadowtheHedgehogWizard That's a real shame, since it's a real pain and is probably not that hard to fix. Thanks for the fast response though! :) Much appreciated! – Monomeeth Jan 3 '18 at 12:09

You must log in to answer this question.

Browse other questions tagged .