10

I was reading an answer on my PC and keeping an eye out for errors in it as I usually do (too much actually). I liked it and upvoted it, and since I found no major errors, I decided to 'cancel' the edit window after I upvoted it.

But accidentally, I hit "save edits" instead of "cancel".

There were no edits made by me. But somehow it saved my "edit" and this is what happened next.

See revision 7. It says "added 6 characters in body".

strange edit history

EDIT — Tried to reproduce it on another answer, but it wasn't funny anymore.­­­­­­

­­­­­­ ­

migrated from interpersonal.meta.stackexchange.com Aug 21 '17 at 20:01

This question came from our discussion, support, and feature requests site for people looking to improve their interpersonal communication skills.

  • 3
    Perhaps it was something mixed with suggested edits? (It's 6 edits minimum to suggest an edit). It's also possible that your vote while the edit window was open registered an event for the edit timeline, and allowed the edit to go through since something may have been registered as being changed. But then I'm only speculating here. – Zizouz212 Aug 14 '17 at 16:16
  • @Zizouz212 That's an interesting possibility. – NVZ Aug 14 '17 at 16:17
  • Hmm, I thought I knew how to reproduce this (add some whitespace at the end of the post) but I guess that doesn't work like I thought it would, after all. :/ – Ilmari Karonen Aug 21 '17 at 22:21
  • See revision 3. – iBug Aug 21 '17 at 23:08
  • 2
    @iBug: Not quite the same: your example shows a couple of changed lines in "side-by-side markdown" view (although it's not quite obvious to me at a glance what you changed there). In NVZ's example, even the markdown diff doesn't show any changed lines at all. – Ilmari Karonen Aug 21 '17 at 23:31
  • One thing to consider with the default message is the grace period. Imagine you send the edit on it's way having added a word with 6 characters without any edit message - the system than appends the edit message. If you click on "edit" again and remove the word within 5 minutes the edit message is still there and won't get changed automatically. As far as I know if you only add or remove a whitespace it won't get shown in the diff, which would explain this weird behaviour and why you aren't able to see what has been changed. – Secespitus Aug 22 '17 at 9:07
  • @Secespitus I just now tried as you said. See revision 3. It shows "[Edit removed during grace period]", not "6 characters added". – NVZ Aug 22 '17 at 9:21
  • "Upvote" is 6 characters, so, in a sense, you added 6 characters. – Dukeling Aug 22 '17 at 9:23
  • @Dukeling Ha! But, really, though? – NVZ Aug 22 '17 at 9:24
  • I was sure you could leave a space at the end... I searched for what I remembered: here, have a look at revision 2. Sadly it does show a space... – Secespitus Aug 22 '17 at 9:26
  • 1
    Voting on a post reloads it, so perhaps this bug happened as a result of voting after an edit by another user. Did you possibly keep the post open for an hour prior to this, so that the last edit was not yet loaded at the time you "saved your edits"? – Dukeling Aug 22 '17 at 16:47
  • @Dukeling since when voting on a post reloads it?? This is more likely some userscript on your side. – Shadow The Curly Braced Wizard Aug 22 '17 at 16:50
  • @ShaWizDowArd For at least the last 5 minutes. I'm not running userscripts. – Dukeling Aug 22 '17 at 16:52
  • @Dukeling can't reproduce. Where exactly you experience this? I tried here on MSE with bunch of random posts with network tab open, there are only the usual AJAX calls. – Shadow The Curly Braced Wizard Aug 22 '17 at 16:54
  • @ShaWizDowArd It reloads it if the post's been edited. I reproduced it on some random post on Stack Overflow just now. – Dukeling Aug 22 '17 at 16:55

You must log in to answer this question.

Browse other questions tagged .