2

I just added a comment here. The poster (眠りネロク) has a non-western username, which I copy-pasted into the comment (I don’t have Japanese language input ability installed on my PC).

However, I notice that doing so failed to activate the "link-to-reference" kind of behavior I've come to expect on SE, meaning that it is unlikely that the poster will know I just tried to tag him with a note.

Is this a failing with the language on SE? (Japanese is well-within the BMP.) Or did I do something wrong?

edit

I do not consider this a duplicate of (above): the question is about using CJK characters with @, not whom can I ping (which I admit I did wrong).

  • Seems your problem related with part of Stack Overflow spam comments prevention system which limits use of CJK characters in comment boxes. Try contacting moderators in SO chatroom to get further explanation about this issue. – Tetsuya Yamamoto Sep 8 '17 at 4:16
  • Ah, I always seem to forget how people can abuse stuff. Thank you! – Dúthomhas Sep 8 '17 at 4:21
  • I doubt it's related but, FYI, you don't have to ping the post creator to get them to ping... sometimes the system intentionally doesn't auto-complete in these cases because it's unnecessary... though that's usually only when it's the first comment or so. For example, I can't direct this comment at you right now. – Catija Sep 8 '17 at 4:23
  • 1
    The CJK hasn't got much to do with it. The dupe does, I think, explain the situation, although it's a bit verbose. Basically, because the post author hadn't commented yet, they weren't in the list, as there was no comment of theirs to reply to in particular, so just a general remark was the only applicable choice. – Nathan Tuggy Sep 8 '17 at 7:41
  • Ah, that makes perfect sense, and I see that now in the dupe. Sorry to have been so dense. – Dúthomhas Sep 8 '17 at 7:54
4

I think this is actually .

It's unnecessary to write @username if it's their own post because they are notified of all comments on the post, regardless of who it's directed to. As such, this is often disabled. I don't know all of the rules but I think that one of them is that it's disabled if the user has never commented on their own post. I do have the Japanese character set on my computer and I can not direct a comment at the OP on that post.

However, if I go to a post that they created but also commented on like this one or a post they didn't create but did comment on like this one, I get an autocomplete simply by typing "@":

Autocomplete feature working as designed

As I noted in my comment earlier, I couldn't ping you when I wrote that comment... though you had commented on your own post, so I'm guessing it's a combination of the quantity of comments in conjunction with whether the OP has commented themselves. I think this has nothing to do with the character set.

Not the answer you're looking for? Browse other questions tagged .