1

How can I view an image on a mobile device?

For example, I want to ask a question. I upload an image for the reference in my question. I post the question, and the image will appear. But when I am trying to see the question on mobile or Stack Exchange/Overflow apps, it shows nothing, not even the description of the image.

I used the default format like this (picture is just an example):

enter image description here

When I am trying to view the image above on my mobile device, it shows nothing.

What is the correct format to view an image that we have uploaded to our posts?

Here what it looks like on my Android:

enter image description here

  • What browser are you using? Is it by any chance a browser like Opera or Chrome with their image compression proxy (data saver, Opera Turbo, etc.) enabled? Or perhaps a browser that doesn't show alt text where it should? – Bob Sep 18 '17 at 3:55
5

It should just work, assuming it uploads (I've done pngs, jpeg and gif, and there's a maximum file size), and both the web page and mobile app scale it as necessary.

A quick google search suggests your phone company - Telkomsel has blocked imgur in the past. I'd try seeing if it works over wifi (with a different ISP?) or to try a proxy (I often use tunnelbear's free tier and app) to test.

Works for me in the mobile website on chrome

enter image description here

And in the app on android.

enter image description here

I suspect if it's not working, the problem lies elsewhere.

  • I confirm I see it on my iosapp too – yagmoth555 Sep 17 '17 at 13:17
  • i have updated my question @Journeyman Geek – gagantous Sep 17 '17 at 13:55
  • 1
    I'd suggest the problem lies elsewhere - maybe your ISP's blocking imgur? – Journeyman Geek Sep 17 '17 at 13:56
  • you are right... i cant acces imgur. okay that's what i wanted to know. and thanks for your answer @JourneymanGeek – gagantous Sep 17 '17 at 13:59
  • telkomsel's apparently blocked imgur in the past so... yeah, looks even more likely. – Journeyman Geek Sep 17 '17 at 14:00
  • In theory, a blocked image should still show the alt text. Assuming the poster hasn't removed the default text and left nothing there. – Bob Sep 17 '17 at 14:17
  • Pretty sure SE dosen't alt text by default. – Journeyman Geek Sep 17 '17 at 14:53
  • @JourneymanGeek The enter image description here you get when you insert an image with the upload tool is rendered as alt text. – Bob Sep 18 '17 at 3:23
  • The image sure did load the alt text, in my ss image upthere, the page didnt completely loaded, so thats why alt text didnt shown up – gagantous Sep 18 '17 at 14:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .